Closed Bug 1065911 Opened 5 years ago Closed 4 years ago

Include default english acoustic and language models on B2G build.

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1051146

People

(Reporter: anatal, Assigned: anatal)

References

(Blocks 1 open bug)

Details

(Whiteboard: [webspeechapi])

Attachments

(4 files, 2 obsolete files)

English AM and LM should be shipped as default on B2G if some specific flag on mozconfig was set.
Blocks: 1051146
No longer blocks: 1049931
Component: Build Config → GonkIntegration
Product: Core → Firefox OS
Adding Sandip comments from old bug (1051146)

 Sandip Kamat 2014-08-19 18:44:10 PDT

My current thought for existing markets of FxOS is to preload English and Spanish "language packs" by default and add other languages on demand. 2 things to note:

1. OEMs can decide to change this config for their markets/regions
2. They can also preload another (or replace existing) language packs

We should have a table indicating memory footprints for them.
Jonas,

can you please point to me into which source folder that I should include the models? I remember that in our conversation you told me they can't stay at $topsrcdir/models, but in some kind of "resources" folder, for example as dictionaries for localization. 

Can you please help me?

Thanks!

Andre
Flags: needinfo?(jonas)
Blocks: 1067683
No longer blocks: 1051146
Flags: needinfo?(bugs)
Wouldn't it make sense to put them close to the speech recognition files.
Similar to what we do for spellchecker's locales 
http://mxr.mozilla.org/mozilla-central/source/extensions/spellcheck/locales/
Flags: needinfo?(bugs)
(In reply to Olli Pettay [:smaug] from comment #3)
> Wouldn't it make sense to put them close to the speech recognition files.
> Similar to what we do for spellchecker's locales 
> http://mxr.mozilla.org/mozilla-central/source/extensions/spellcheck/locales/

Ok, will put them there so.
Assignee: nobody → anatal
Attachment #8504467 - Flags: review?(bugs)
Comment on attachment 8504467 [details] [diff] [review]
This patch includes the binary acoustic models and patches the build system to put them at /dist/bin/ folder

The patch is too large to upload, since include the acoustic models binary files.

So this is the url to download it:

https://www.dropbox.com/s/sj5oy9totwbkjvh/0002-Include-pocketsphinx-english-models-in-content-media.patch?dl=0
Comment on attachment 8504467 [details] [diff] [review]
This patch includes the binary acoustic models and patches the build system to put them at /dist/bin/ folder

You should upload the build changes as a patch
(and they need a build peer review).


Btw, how much memory these acoustic models will take on b2g?
Attachment #8504467 - Flags: review?(bugs) → review-
(In reply to Olli Pettay [:smaug] from comment #7)
> Comment on attachment 8504467 [details] [diff] [review]
> This patch includes the binary acoustic models and patches the build system
> to put them at /dist/bin/ folder
> 
> You should upload the build changes as a patch
> (and they need a build peer review).
> 

Ok, I will upload them split that way we discussed.

> 
> Btw, how much memory these acoustic models will take on b2g?

In this comment we have a brief benchmark in Flame, in exact point where it recognition occurs: https://bugzilla.mozilla.org/show_bug.cgi?id=1051148#c14
Attachment #8504467 - Attachment is obsolete: true
Attachment #8505933 - Flags: review?(bugs)
Attachment #8505933 - Attachment is obsolete: true
Attachment #8505933 - Flags: review?(bugs)
Attachment #8505979 - Flags: review?(bugs)
Comment on attachment 8505980 [details] [diff] [review]
Bug 1065911 - Including sendump to english acoustic model folder

The file should go to
dom/media/webspeech/recognition/pocketsphinx/models/en-us-semi
With that, r+

(assuming the rest of the patch are ok.)
Attachment #8505980 - Flags: review?(bugs) → review+
Did you ever send the email to dev.platform?
Comment on attachment 8505981 [details] [diff] [review]
Bug 1065911 - Including acoustic model binary files

All these need to go to
dom/media/webspeech/recognition/pocketsphinx/*
Attachment #8505981 - Flags: review?(bugs) → review+
Comment on attachment 8505982 [details] [diff] [review]
Bug 1065911 - Including default cmu07a.dic to models folder

Same here
Attachment #8505982 - Flags: review?(bugs) → review+
Comment on attachment 8505979 [details] [diff] [review]
Bug 1065911 - Patch build system to include acoustic models folder in staging

And same here. dom/media/webspeech/recognition/pocketsphinx/*


And no patch should land before some dev.platform discussions.
Attachment #8505979 - Flags: review?(bugs) → review+
Olli, can you help here. See comment 2.
Flags: needinfo?(jonas) → needinfo?(bugs)
Olli, also can you describe what should be covered in dev.platform?
Whiteboard: [webspeechapi]
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1051146
Flags: needinfo?(bugs)
You need to log in before you can comment on or make changes to this bug.