Message on console: alert, asking if the user wants to auto unsubscribe from

VERIFIED INVALID

Status

SeaMonkey
MailNews: Message Display
VERIFIED INVALID
17 years ago
10 years ago

People

(Reporter: mozbug1, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101202

In the xterm from where I started mozilla I see:
alert, asking if the user wants to auto unsubscribe from baen.SchmitzProject

... presumably because that newsgroup no longer exists.  However mozilla never
prompted me, it only left that message on the console.


Reproducible: Always
Steps to Reproduce:
I guess you'd have to have a news server you could fiddle with the reproduce
this one.  Create a group, subscribe to it, quit mozilla, delte the group, then
restart mozilla.

Actual Results:  No prompt was shown.

Expected Results:  ??

BTW the news server in question is bar.baen.com
200 WBNews server 1.36 ready - posting allowed
480 Authentication required:

And, I can't test auto-subscribe yet until bug 105183 is fixed.

Auto-subscribe should allow me to get into the state where I see this message on
the console.
Summary: Message on console: alert, asking if the user wants to auto unsubscribe from → Message on console: alert, asking if the user wants to auto unsubscribe from
(Reporter)

Comment 2

17 years ago
Go to http://www.baen.com/bar/Default.htm to register to gain access.
Did you only see this message once?  At the time you saw this message on the 
console, were you subscribed to that newsgroup, or was this totally random?
I ran mozilla.exe -console -mail and only got:
stdout directed to dynamic console
stderr directed to dynamic console

but then again, this would have to be in your .rc file.  Let me keep trying ;-)
BTW, test account is as follows:

Your Login Name: stephend
Your Password: LZK1DVDLHU

(Reporter)

Comment 5

17 years ago
I was subscribed to the newsgroup.  A further look indicated that the newsgroup
wasn't on the server any more.  I usually see it only once, but I was able to
get the message again by fiddling with it.  Try manually adding the newsgroup to
your rc file and see what happens.
Okay I added 'baen.SchmitzProject:' to my bar.baen.com.rc file, but no luck. 
Also, I'm still hitting bug 105183 when doing an auto-subscribe url
(news://bar.baen.com/baen.SchmitzProject), getting the "It appears
baen.SchmitzProject doesn't exist on the server.  Would you like to unsubscribe
form it" dialog, which I cancel (to try to get that newsgroup in my .msf files,
too), I hit the Trunk crash downloading newsgroup headers [@
nsMsgDatabase::GetThreadContainingMsgHdr] 
"alert, asking if the user wants to auto unsubscribe from baen.SchmitzProject"

that's must be from an old build.

that was fixed on oct 13th.

http://bugzilla.mozilla.org/show_bug.cgi?id=39584

see

http://bonsai.mozilla.org/cvsview2.cgi?
diff_mode=context&whitespace_mode=show&file=nsNntpIncomingServer.cpp&root=/cvsro
ot&subdir=mozilla/mailnews/news/src&command=DIFF_FRAMESET&rev1=1.110&rev2=1.111
Seth, thanks, I should've LXR'd for that printf code.  Resolving as invalid,
since I see the printf has been removed!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.