Intermittent test_everythingme_add_collection_save_bookmark on Flame

RESOLVED WORKSFORME

Status

P1
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: zcampbell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
This test is failing intermittently on Flame/Jenkins.

It looks like a timing problem in the test, it needs some investigation.


Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py", line 264, in run
testMethod()
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/everythingme/test_everythingme_add_collection_save_bookmark.py", line 40, in test_everythingme_add_collection
add_link.tap_add_bookmark_to_home_screen_dialog_button()
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/regions/bookmark_menu.py", line 28, in tap_add_bookmark_to_home_screen_dialog_button
self.wait_for_condition(lambda m: self.apps.displayed_app.name != self.name)
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 56, in wait_for_condition
Wait(self.marionette, timeout).until(method, message=message)
File "/var/jenkins/1/workspace/flame.b2g-inbound.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.2 seconds
I can't reproduce this fail. 

Looking at Jenkins this test is passing OK on B2G-inbound kk builds
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.b2g-inbound.ui.functional.smoke/lastCompletedBuild/testReport/test_everythingme_add_collection_save_bookmark/TestEverythingMeAddCollectionSaveBookmark/test_everythingme_add_collection/history/
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.