If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Translating a page always shows error

RESOLVED WONTFIX

Status

()

Firefox
Translation
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: ramesh_hrsh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8488039 [details]
The picture of the problem

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.103 Safari/537.36

Steps to reproduce:

In aurora, using the translation option. 


Actual results:

When I clicked translate option, Translating page content appeared and then it said "there has been error translating this page"


Expected results:

The expected result should have been translation of the webpage
(Reporter)

Comment 1

3 years ago
Kindly look into the issue, as I've tried many times to translate and all the times it shows only error

Updated

3 years ago
Group: mozilla-employee-confidential
Component: Community Giving → Untriaged
Product: mozilla.org → Firefox
Version: other → unspecified

Comment 2

3 years ago
I don't see any native tool in Firefox tro translate the webpage.
Are you using an add-on to do that?
Flags: needinfo?(ramesh_hrsh)
(Reporter)

Comment 3

3 years ago
Dude, It's the aurora version. I'm in the QA team. It's still being tested. The aurora version has got translation option. And when the translate option is used, it always says error.
Flags: needinfo?(ramesh_hrsh)
Component: Untriaged → Translation
How did you activate the translation feature? Did you set up an API key to use?
(Reporter)

Comment 5

3 years ago
Yes I did!
Maybe the API key was typed incorrectly (ran into that myself a few times..). I just verified using latest Aurora that the translation works as expected.
Having the same issue - this new feature hasn't worked for me yet.
I am currently on 35.0a2 (2014-11-27); browser lang: German; Intel Mac OS X 10.9;
The translation feature seems activated by default now.
(In reply to Albert Scheiner from comment #7)

> The translation feature seems activated by default now.

What makes you think this?
(In reply to Florian Quèze [:florian] [:flo] from comment #8)
> (In reply to Albert Scheiner from comment #7)
> 
> > The translation feature seems activated by default now.
> 
> What makes you think this?

Because the toolbar started to appear for me on non-German sites from Aurora 33 or 34 onwards automatically. I am pretty sure I didn't turn it on manually (even though my memory might trick me there!?).

Comment 10

3 years ago
I'm on FIREFOX_38_0b5_RELEASE x64
Work fine...
This "bing.apiKeyOverride" (J5dY1fzkZwQP2Mq56ssXFF/G0dwrscNmCjSgaxl0CNE=) don't work any more. All you need is a new bing.apiKeyOverride and bing.clientIdOverride.

Comment 11

3 years ago
Created attachment 8594282 [details]
338de50530.jpg

proof working

Comment 12

3 years ago
reporter, is it still an issue for you?
Flags: needinfo?(ramesh_hrsh)
This error is not a bug, but it's because there's no valid API key right now to use the feature. We had it during a period of testing in the past but right now it's not active.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(ramesh_hrsh)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.