[flame-kk] Fail to get paired device list on Settings or Gallery sharing via bluetooth

RESOLVED FIXED

Status

Firefox OS
Bluetooth
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: shawnjohnjr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Fail to get paired device list on Settings or Gallery sharing via bluetooth
STR:
1. Pair with one remote bluetooth device
2. Turn off bluetooth
3. Turn on bluetooth again
4. Settings app cannot load paired device
Depends on: 1065999
This bug caused by CAF sending non-AOSP bt_property_t BT_PROPERTY_REMOTE_TRUST_VALUE property, when we verified the input value, we found that value doesn't exist, thus return NS_ERROR_ILLEGAL_VALUE.

see: http://dxr.mozilla.org/mozilla-central/source/dom/bluetooth/bluedroid/BluetoothInterface.cpp#342

This shall be fixed from CAF side, see bug 1065999
Hi Shawn,

Since bug 1065999 has been fixed for both master and 2.1, please double check if we could close this bug.

Thanks.
Flags: needinfo?(shuang)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(shuang)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.