Closed Bug 1066243 Opened 5 years ago Closed 5 years ago

[Status Bar][Battery] Battery indicator not always properly updating when charging/disconnecting

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S9 (21Nov)
blocking-b2g 2.1+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: jschmitt, Assigned: gmarty)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(2 files)

271.34 KB, text/plain
Details
46 bytes, text/x-github-pull-request
apastor
: review+
etienne
: feedback+
Details | Review
Attached file log.txt
Description:
Battery indicator on the status bar does not update in a timely matter when connecting/disconnecting to a wall outlet or a pc.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140911064110
2) Open the Settings app
3) Connect the Phone to pc or wall outlet
4) Disconnect the phone
5) Reconnect the phone
  
Actual:
The Battery indicator does not update or does not update in a timely matter.
  
Expected: 
The Battery indicator updates immediately upon connecting to a power source.
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140911064110
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: 98ea98c8191a
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  
Notes:
Repro frequency: 3/5
See attached: logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
qawanted for branch checks.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
This bug repro's on Flame KK builds: Flame 2.2, Flame 2.1 and OpenC 2.2

Actual Results: Lightning bolt in the battery indicator in the status bar is not updating timely when plugging or unplugging the phone from USB or wall.

Repro Rate: 10/10

Device: Flame 2.2
BuildID: 20140912061053
Gaia: b72909030e214175144342f7e5df7e88a2b52fd4
Gecko: 59d4326311e0
Version: 35.0a1 (2.2)
Firmware: v165
------------------------------------------------
Device: Flame 2.1
BuildID: 20140912081053
Gaia: 59e5c2467b7b8219ed194a0d0a94c6ed59af95be
Gecko: b09d2857b74e
Version: 34.0a2 (2.1)
Firmware: v165
------------------------------------------------
Device: Open_C 2.2
BuildID: 20140912061053
Gaia: b72909030e214175144342f7e5df7e88a2b52fd4
Gecko: 59d4326311e0
Version: 35.0a1 (2.2)
Firmware: P821A10v1.0.0B06_LOG_DL

------------------------------------------------
------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.0, Flame 1.4 Base

Actual Result: Charging icon in the status bar correctly reflects the user having the device connected and charging or not.

Repro Rate: 0/5 attempts

Environmental Variables:
Device: Flame 2.0
BuildID: 20140911220254
Gaia: 91dd0e596aa7c124dd968e1474b23e7992dc35a1
Gecko: a66168598533
Version: 32.0 (2.0) 
Firmware Version: v165
-------------------------------------------------
Device: Flame 1.4
BuildID: 20140814202332
Gaia: 129211661489feb60bbd6772a44081d23b374f17
Gecko: 
Version: 30.0 (1.4)
Firmware: v165
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
QA Contact: croesch
triage - not nomming - moderate repro rate, graphical issue, additionally - there is also a LED light next to the camera shutter that comes on when you plug in to indicate charging and this comes on immediately when plugging in independent of the icon.
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
[Blocking Requested - why for this release]: regresssion

This is an annoying regression and can easily be a partner blocker.
We also can't depend on that LED light which is specific to Flame hardware design.

Flagging for QA to find the regressed bug. Thanks!
blocking-b2g: --- → 2.1?
Component: Gaia::System::Window Mgmt → Gaia::System
Flags: needinfo?(gmarty)
Whiteboard: [systemsfe]
I see where is the issue. Let me work on a fix.
Flags: needinfo?(gmarty)
Assignee: nobody → gmarty
Attached file Github PR
Etienne, here is a patch. Can you review it when you get a chance?
Attachment #8520696 - Flags: review?(etienne)
We need battery indicator working. Not sure if this is a regression though.
blocking-b2g: 2.1? → 2.1+
Removing regression window tag because a patch is already attached (awaiting review) and finding a window might waste resources and be unnecessary. If some reason the window is still needed or needed later, please re-tag it.
QA Contact: croesch
(In reply to Gregor Wagner [:gwagner] from comment #8)
> We need battery indicator working. Not sure if this is a regression though.

This is clearly a regression per comment 2.

It's better if we could find the regressed bug and link it -- :gmarty should be able to help or we would have to re-flag regressionwindow-wanted. Clearly constructing the feature-regression relationship graph on Bugzilla will help us make better feature & engineering planning in the future.
Reflagging for regression window per comment 10.
Comment on attachment 8520696 [details] [review]
Github PR

Just a question on github but f+ otherwise.
Forwarding the final review to Alberto to get more eyes on the Statusbar code.
Attachment #8520696 - Flags: review?(etienne)
Attachment #8520696 - Flags: review?(apastor)
Attachment #8520696 - Flags: feedback+
This bug is caused by Bug 1042105 so the regression window should incriminate commit https://github.com/mozilla-b2g/gaia/commit/6d02931dc9248edf66207066a0c01ebd3e279f8d.
Comment on attachment 8520696 [details] [review]
Github PR

It looks good to me. Thanks!
Attachment #8520696 - Flags: review?(apastor) → review+
Landed in master in https://github.com/mozilla-b2g/gaia/commit/d13f29ef7b1656dbb555730dc161f89a1d25ce48
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8520696 [details] [review]
Github PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Status bar icons prioritisation.
[User impact] if declined: There can be a lag between the time the battery state changes and the time this change is reflected in the minimised status bar.
[Testing completed]: This fix has a fairly good coverage in terms of unit tests, manual testing would be good too
[Risk to taking this patch] (and alternatives if risky): Very low, the change only affects a single function.
[String changes made]: None.
Attachment #8520696 - Flags: approval-gaia-v2.1?(fabrice)
This issue occurs on the earliest available Flame build so no regression window can be found.

Environmental Variables:
Device: Flame 2.0
BuildID: 20140418120005
Gaia: 76c94ac5dc3b8e17cc23d9cc3e2662b0d5d28b2e
Gecko: 45ba19361b97
Version: 31.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:31.0) Gecko/31.0 Firefox/31.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Target Milestone: --- → 2.1 S9 (21Nov)
Attachment #8520696 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
This issue is verified fixed on 2.2.

Result: The battery indicator is displayed properly when the device is connected to a power source.

Device: Flame 2.2 (319mb, KK, Shallow Flash)
BuildID: 20141113040205
Gaia: be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko: ab137ddd3746
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
============================================

Leaving verifyme for 2.1 patch uplift.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Needs rebasing for v2.1 uplift.
Flags: needinfo?(gmarty)
The rebased PR for v2.1 is here: https://github.com/mozilla-b2g/gaia/pull/26152
Flags: needinfo?(gmarty)
Duplicate of this bug: 1099037
This issue is verified fixed on 2.1.

Result: The battery indicator is displayed properly when the device is connected to a power source.

Device: Flame 2.1 (319mb, KK, Shallow Flash)
BuildID: 20141117001201
Gaia: 81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko: 3572aa3e6766
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.