All users were logged out of Bugzilla on October 13th, 2018

Improve the layout of the repo menu

RESOLVED FIXED

Status

P4
normal
RESOLVED FIXED
4 years ago
a year ago

People

(Reporter: KWierso, Assigned: KWierso)

Tracking

Details

(URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

4 years ago
Created attachment 8488348 [details]
Mockup

Bug 1045618 changed the repo panel into a plain dropdown menu, which is much nicer for scanning than the panel ended up being.

I think the dropdown menu could be further cleaned up by making it a two-column menu, so it takes up less vertical space.

Attached is kind of what I was thinking this could be.

On the top of the left column, we could have all of the repos from the "development" group. To the right of that, everything from "release-stabilization".

Below them, the rest of the categories can be laid out in such a way that everything fits next to the "projects" group.



This layout keeps most of the sheriffs' frequently accessed repositories at the top of the menu, while still separating the development and stabilization branches. 

On decently sized/resolutioned monitors, the entire menu's contents should be visible with minimal or no scrolling required.
I might have a look at this, and will assign myself if appropriate. Atm now having some issues pulling job data from dev/stage/prod.

Comment 2

4 years ago
The mockup looks good; Ryan/Tomcat what do you think? (Compare to current treeherder-dev http://treeherder-dev.allizom.org/ )
OS: Windows 8.1 → All
Priority: -- → P3
Hardware: x86_64 → All
lgtm!

Updated

4 years ago
Blocks: 1053985
Assignee: nobody → tojonmz
Status: NEW → ASSIGNED

Updated

4 years ago
No longer blocks: 1059400
Sorry I've been fixing a bunch of other bugs and haven't had time for this one yet. I'll un-assign myself for now. If someone else wants to take it, feel free. I will investigate it more if/when I can.
Assignee: tojonmz → administration
Status: ASSIGNED → NEW
Assignee: administration → nobody

Updated

4 years ago
Blocks: 1125264

Updated

4 years ago
Blocks: 1125352
No longer blocks: 1053985

Updated

4 years ago
No longer blocks: 1125264

Updated

4 years ago
Summary: Further cleanup of the repos menu → Improve the layout of the repo menu

Updated

4 years ago
Priority: P3 → P4
Created attachment 8856307 [details] [review]
[treeherder] KWierso:repomenu > mozilla:master
(Assignee)

Updated

2 years ago
Assignee: nobody → wkocher
(Assignee)

Comment 6

2 years ago
Created attachment 8856308 [details]
Screenshot of PR

Below the fold is the rest of the 'taskcluster' and 'qa automation tests' group repos, and the entirety of the 'other' group.
(Assignee)

Updated

2 years ago
Attachment #8856307 - Flags: feedback?(emorley)
(Assignee)

Updated

2 years ago
Attachment #8856308 - Flags: feedback?(cbook)
Comment on attachment 8856308 [details]
Screenshot of PR

looks nice ! 

at some point i guess for community members some tooltips at the repos would be nice but i guess that can come at a later point
Attachment #8856308 - Flags: feedback?(cbook) → feedback+
(Assignee)

Comment 8

2 years ago
I've added tooltips to the repo group headers.

Comment 9

2 years ago
Comment on attachment 8856307 [details] [review]
[treeherder] KWierso:repomenu > mozilla:master

Looks good!

I wonder if we should also move the comm-* repos to their own group?
Attachment #8856307 - Flags: feedback?(emorley) → feedback+
(Assignee)

Comment 10

2 years ago
Comment on attachment 8856307 [details] [review]
[treeherder] KWierso:repomenu > mozilla:master

I've done a major rewrite of the PR. 

It's now arranged into two columns with css grid, rather than just floats.

There is a new 'comm-repositories' repo group, and all of the comm-* repos have been moved into this new group.

Descriptions of the repository groups have been added to each repo group, and the UI shows them in the menu via tooltips.

There's a new field in the repository model named 'is_try_repo' which is set to true for the try repos. I've moved the try repos out of the try repo group and into more fitting repo groups. This effectively removes the try repo group. The UI now looks for this new field rather than the try group for a number of checks.

A number of repos haven't had any pushes in over a month. I've marked a bunch of them as onhold to trim down the repo menu a bit. (Happy to undo some of these if they are in fact still active.)
Attachment #8856307 - Flags: review?(emorley)
(Assignee)

Comment 11

2 years ago
Created attachment 8861713 [details]
Repo menu with latest PR

Here's what the repo menu looks like with all of these changes.
Attachment #8488348 - Attachment is obsolete: true
Attachment #8856308 - Attachment is obsolete: true
Comment on attachment 8856307 [details] [review]
[treeherder] KWierso:repomenu > mozilla:master

Have left some comments :-)
Attachment #8856307 - Flags: review?(emorley)
(Assignee)

Updated

2 years ago
Attachment #8856307 - Flags: review?(emorley)

Updated

2 years ago
Attachment #8856307 - Flags: review?(emorley) → review+
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

a year ago
Duplicate of this bug: 1045686
You need to log in before you can comment on or make changes to this bug.