All users were logged out of Bugzilla on October 13th, 2018

[Ringtones][Music]Both ringtones & music play at the same time

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: ankit93040, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [g+][LibGLA, TD-95806, WW, B] [LibGLA, TD-101659, QE2, B] )

Attachments

(1 attachment)

WIP
358 bytes, text/html
squib
: feedback-
Details
(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120 Safari/537.36

Steps to reproduce:

1. Go to music & play a song.
2. Pause the song.
3. Click on share -> Ringtones
4. In create ringtone screen, play the tone by pressing play button
5. Notification(statusbar) area scroll down.
6. Play the music.


Actual results:

music plays from both create ringtone screen & music app


Expected results:

It should play from only music
(Reporter)

Updated

4 years ago
Whiteboard: [g+][LibGLA, Dev, B]
(Reporter)

Updated

4 years ago
Flags: needinfo?(squibblyflabbetydoo)
Flags: needinfo?(alive)

Comment 1

4 years ago
Yeah, that's about what I'd expect to happen, since we use a weird hack to pause the music app. This will probably be fixed when we rewrite the audio competition code, but luckily this is a really narrow edge case, so I don't think this would block a release.
Flags: needinfo?(squibblyflabbetydoo)
(Reporter)

Comment 2

4 years ago
Hi Dominic

Please see this.. Jim told that you are the right one for this.

Thanks
Flags: needinfo?(dkuo)
(Reporter)

Comment 3

4 years ago
Hi Alive

there is a way to resolve this, obviously at the cost of other things.
  i.> Lets stop the user from descending down the Utility tray (status bar). 
    It doesn't look good at all.
 ii.> whenever user scrolls down the Utility tray (status bar) & if he is in ringtone app, lets close the activity.
     I don't know how system app can close an activty forcibly? so couldn't try this.

What do you say. second one sounds reasonable.

Alive, whats your opinion on this. Will it have any defect on the system or crash?

Thanks!

Comment 4

4 years ago
(In reply to ankit93040 from comment #2)
> Hi Dominic
> 
> Please see this.. Jim told that you are the right one for this.
> 
> Thanks

Jim is correct in comment 1, it's because both music and ringtones apps are visible(document.hidden is false) so those two channels(ringer and content) are able to play sounds at the same time. Currently I think we are unable to fix this without a hack, like we already did for the music and ringtones apps. Also I agree this should not be a blocker cause it's such an edge case.
Flags: needinfo?(dkuo)
(Reporter)

Comment 5

4 years ago
Hi Wayne

Greetings!

Please do something for this.
It's a blocker for us.

Thanks a lot.
(Reporter)

Updated

4 years ago
Flags: needinfo?(wchang)
I also don't see this as a blocker given the steps and it's use case.
Flags: needinfo?(wchang)

Comment 7

4 years ago
(In reply to Dominic Kuo [:dkuo] from comment #4)
> Jim is correct in comment 1, it's because both music and ringtones apps are
> visible(document.hidden is false) so those two channels(ringer and content)
> are able to play sounds at the same time. Currently I think we are unable to
> fix this without a hack, like we already did for the music and ringtones
> apps. Also I agree this should not be a blocker cause it's such an edge case.

We might (emphasis on "might") be able to extend our hack to work a bit like what happens when you're on a phone call: disable the ability for music to play until the ringtone creation activity ends. I'd rather not do that though, since if things go wrong, the music app will be broken until you kill and restart it. Even so, there are probably other weird things you'd be able to do to subvert this.
Flags: needinfo?(alive)
(Reporter)

Updated

4 years ago
Whiteboard: [g+][LibGLA, Dev, B] → [g+][LibGLA, TD-95806, WW, B]
(Reporter)

Comment 8

4 years ago
Dear Vance

Greetings!

We need your kind help on this. Please if you can assign this to somebody as it is a blocker for us(v2.0).

Thanks

Regards
Ankit
Flags: needinfo?(vchen)

Comment 9

4 years ago
Hi Dominic,

How about using same hack for ringtone app which is used in music app for pausing.
Music app will set the hack properties & ringtone app will listen for it for pausing ringtone.

Thanks.
Flags: needinfo?(dkuo)
(Reporter)

Updated

4 years ago
Whiteboard: [g+][LibGLA, TD-95806, WW, B] → [g+][LibGLA, TD-95806, WW, B] [LibGLA, TD-101659, QE2, B]

Comment 10

4 years ago
Created attachment 8497482 [details]
WIP

Hi,

I am adding  WIP for my approach in comment 9.
Thanks,
Attachment #8497482 - Flags: feedback?(squibblyflabbetydoo)
Attachment #8497482 - Flags: feedback?(dkuo)

Comment 11

4 years ago
Comment on attachment 8497482 [details]
WIP

I prefer not to land some similar hacks on master unless this bug become a blocker.
Attachment #8497482 - Flags: feedback?(dkuo)
Flags: needinfo?(dkuo)

Comment 12

4 years ago
Comment on attachment 8497482 [details]
WIP

I don't think this is the right way to go about this. I think it makes a lot more sense for the music to be locked in a "paused" state until ringtone selection is done.

Also, like Dominic said, I strongly oppose any more hacks added to this part of the code unless this bug gets marked as a blocker, so please request blocking first. However, I disagree that this is a blocker in the first place, since it's a rarely-encountered edge case that doesn't actually *break* anything. Still, if you can convince project management that this is a blocker, I'm willing to hold my nose and land a patch to fix this.

I'd very much prefer that we fix this as a part of the audio competition rework. I'm not sure how that's progressing, but perhaps Dominic knows, since I believe he was working on it in the past.

(Finally, I imagine a lot of this is going to change when Dominic lands his work to split up the music app into two pieces.)
Attachment #8497482 - Flags: feedback?(squibblyflabbetydoo) → feedback-

Comment 13

3 years ago
This doesn't happen anymore, thanks to changes to the AudioChannel code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.