Large downloads stop before completion.

VERIFIED WORKSFORME

Status

()

--
major
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Peter, Assigned: darin.moz)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.5+) Gecko/20011022

Large downloads stop before completion.

For several days (builds) now, when I try to download large files (>20MB), the
download will go for a while and then just stop dead in its tracks :(

This happends at home (win98, T-DSL) and at work (winNT, router). This is
particularly annoying (and VERY timeconsuming) since Mozilla doesn't even have
the semblance of a download manager (resumable DL, last downloaded files list,
segmented DL, multiple sources DL, DL later, etc.).

An example (110 MB):
http://xferla1.fileplanet.com/%5E1560229720/movies/Mo_130.zip
(Reporter)

Comment 1

17 years ago
Another example (30 MB):
ftp://3dgamers.in-span.net/pub/3dgamers/games/returnwolfenstein/rtcwolfenstein_trailer.zip

I was downloading both files at the same time. I was also reading (some) mail
and doing (some) browsing. Still, downloads should never just FREEZE like that!
Keywords: mozilla0.9.6, nsbeta1, nsCatFood
Whiteboard: I would also call this a DATALOSS and HANG bug! Agreed?

Comment 2

17 years ago
would you at least try to pick a component?
Assignee: asa → darin
Component: Browser-General → Networking: HTTP
QA Contact: doronr → tever

Comment 3

17 years ago
http://xferla1.fileplanet.com/%5E1560229720/movies/Mo_130.zip
HTTP/1.1 403 Forbidden

The second one downloaded to completion w/ using a branded release of 0.9.4.1 (i
think that's what we'd call it ...)

removing the cat since i was using it.
Keywords: nsCatFood
Whiteboard: I would also call this a DATALOSS and HANG bug! Agreed?

Comment 4

17 years ago
Same result as timeless with 2001102421 trunk linux

Comment 5

17 years ago
marking wfm since I can not seem to reproduce this either.

Reporter, are you still seeing this with a more recent build?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
I've stopped using mozilla to download large files. I copy/paste the url into
GetRight. I'm very sorry, but I currently don't have enough time right now to
test this. If you all say that it works now, then OK (as long as you're not all
on the same ISP).

PS. Mozilla really needs the ability to resume downloads accross sessions and
after a crash. You can imagine how infuriating it is if a download becomes
useless after you've been waiting for the file an hour or two...

Comment 7

17 years ago
marking verified, please re-open if anyone can reproduce this

Peter, I sent a note to one of the product mngrs reminding him that we do not
support that feature yet.  I am not sure if or when it will be included but I
do think it is a known issue.   
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.