[Contacts] [Regression] Cannot add a new contact with only date (birthday or anniversary)

VERIFIED FIXED

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Jose Manuel Cantera, Assigned: Jose Manuel Cantera)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
STR:

Try to add a new contact that only has a date as non-empty field. 

Actual:

The done button remains disabled

Expected:

The done button is enabled and the contact can be added
(Assignee)

Updated

3 years ago
Keywords: qawanted
Hum,

I think we removed that on purpose during the form redesign. I though it was an error, creating a contact just with a date ... cannot see the use case.

But if product wants it, let's reenable it.
(Assignee)

Comment 2

3 years ago
Created attachment 8488512 [details]
23996.html
Attachment #8488512 - Flags: review?(francisco)
(Assignee)

Comment 3

3 years ago
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #1)
> Hum,
> 
> I think we removed that on purpose during the form redesign. I though it was
> an error, creating a contact just with a date ... cannot see the use case.
> 
> But if product wants it, let's reenable it.

Yes, by design it can be added a contact that only has one field filled, including bday
Comment on attachment 8488512 [details]
23996.html

Excellent and super clean solution.

Good to see you back!
Attachment #8488512 - Flags: review?(francisco) → review+
(Assignee)

Comment 5

3 years ago
landed on master:

https://github.com/mozilla-b2g/gaia/commit/c1422c2e16c3862624b9644a50dfac5fd42cda1c
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Keywords: verifyme
Tested and working
2.2
Flame
Gecko-713c41b
Gaia-32d82d2
Status: RESOLVED → VERIFIED
Keywords: qawanted, verifyme
You need to log in before you can comment on or make changes to this bug.