E10S (multi-process) - Netflix videos have sound but no video (Silverlight)

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: erik, Unassigned)

Tracking

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140911064110

Steps to reproduce:

Switched Nightly build to E10S (multi-process) mode on 35.0a1 (2014-09-11). Tried to play Netflix video.


Actual results:

Sound from Netflix video plays but the video is absent from the page. 


Expected results:

Video should be visable
Blocks: e10s
Component: Untriaged → Video/Audio
Product: Firefox → Core
tracking-e10s: --- → ?
Component: Video/Audio → Silverlight (Microsoft)
Product: Core → Plugins
Version: 35 Branch → unspecified
Silverlight wont be able to paint until bug 669200 is resolved
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: E10S (multi-process) - Netflix videos → E10S (multi-process) - Netflix videos (Silverlight)
Simple test for no graphical output can be done  via the silvlight sample at 
http://bubblemark.com/silverlight2.html, this too displays nothing.
Duplicate of this bug: 1079677
Fixed by bug 669200.
Fixed?
You mean "will be fixed"
Because up until now nothing is fixed
Still no picture on http://bubblemark.com/silverlight2.html
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141104030202 CSet: 5dde8ea48fef
(In reply to martin from comment #6)
> Still no picture on http://bubblemark.com/silverlight2.html
> Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101
> Firefox/36.0 ID:20141104030202 CSet: 5dde8ea48fef

thanks for testing, this test works with the patches in the parent bug.

(In reply to Jim Mathies [:jimm] from comment #4)
> Fixed by bug 669200.

*will be* fixed by bug 669200.

sorry for the confusion.
Summary: E10S (multi-process) - Netflix videos (Silverlight) → E10S (multi-process) - Netflix videos have sound but no video (Silverlight)
This should be fixed in today's nightly. Would appreciate someone with netflix access confirming.
Jim,
tested with
http://bubblemark.com/silverlight2.html Worksforme
http://www.netflix.com/ Worksforme

BuildID Tested On: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141114030206 CSet: 7f0d92595432
Flags: needinfo?(jmathies)
thanks!
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jmathies)
Resolution: --- → WORKSFORME
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.