Closed Bug 1066565 Opened 7 years ago Closed 7 years ago

[v2.2] [v2.1] Usage app view is empty when opening for the second time

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1064507

People

(Reporter: RobertC, Unassigned)

Details

(Keywords: regression, Whiteboard: [fromAutomation])

Attachments

(2 files)

Attached image usage.png
If you open the usage app, then the browser and then the app again no information is displayed.
Test link: https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/tests/functional/cost_control/test_cost_control_reset_wifi.py

This issue can be reproduced with both manual and automated testing.
Local reproduction rate: 5 out of 5. I could reproduce this on both 319MB and 512MB devices.

While running the automated test, all of the runs after the first one end with a crash:
https://crash-stats.mozilla.com/report/index/1b7cf38f-d20e-497d-9ccf-577102140912

STR:
1. connect to wifi
2. open usage app and accept default settings
3. disable mobile usage and enable wifi usage
4. tap homescreen button
5. open browser and navigate to a page, wait for a few seconds
6. tap homescreen button
7. open usage app

Expected result:
Information regarding wifi usage should be displayed.

Actual result:
No information is visible (screenshot attached)

Build info flame v2.2:
Gaia      6cb5e0100d70313e4922c8d34bf20dcdd66ef616
Gecko     https://hg.mozilla.org/mozilla-central/rev/0be3ea11a4c7
BuildID   20140911160248
Version   35.0a1
ro.build.date   Fri Jun 27 15:57:58 CST 2014
ro.bootloader   L1TC00011230
ro.build.version.incremental   110
Attached file logcat.txt
Logcat from when I ran the steps manually.
The issue is reproducible on latest v2.1 too, manually, by following STR from comment 0, and also by running the automated test: https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/tests/functional/cost_control/test_cost_control_reset_wifi.py
but I'm not getting any crash after running the test several times. 

Link to jenkins report: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-319.mozilla-aurora.ui.functional.non-smoke/37/HTML_Report/

Device firmware (date) 	16 Jun 2014 01:51:29
Device firmware (incremental) 	109
Device firmware (release) 	4.3
Device identifier 	flame
Gaia date 	11 Sep 2014 17:29:07
Gaia revision 	7fe8807b384e
Gecko build 	20140912000203
Gecko revision 	1d4b0fc511dc
Gecko version 	34.0a2
Summary: [v2.2] Usage app view is empty when opening for the second time → [v2.2] [v2.1] Usage app view is empty when opening for the second time
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1064507
You need to log in before you can comment on or make changes to this bug.