[Youtube] Connect your accounts feature is not working properly

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: joseenrique.alvarezfernandez, Assigned: fzzzy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sprd387380])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
The connection with Facebook and Twitter does not work. After you tap on Connect, log into Facebook/Twitter and finish the process with apparent success, the account is still not connected with the Youtube account, which can be checked both in the mobile app and in the regular Youtube website on a PC.

Alos, the disconnection from Facebook and Twitter does not work. After you tap on the Disconnect button, nothing happens and the connection remains.
(Assignee)

Comment 1

4 years ago
I was able to repro this. I was unable to connect facebook to yt. I don't have any suggestions about how to fix it, yet.
Status: NEW → ASSIGNED
Hi Donovan -

Could we inform Facebook or Twitter about this issue and see what they can do about it?

Thanks
Flags: needinfo?(dpreston)

Comment 3

4 years ago
I would think we would need to reach out to Youtube on this matter, as opposed to FB/twitter.
(Assignee)

Comment 4

4 years ago
I don't think there's anything youtube can do to fix it. I think it's just the way cookie jars work in apps on firefox os. We need to have someone at mozilla look into it, and if it is a bug that yt can take care of, then we can have them fix it once we are confident it is not a firefox os issue.
Flags: needinfo?(dpreston)

Comment 5

4 years ago
@Jose-  Can you please provide some more information about this bug.

Where did this bug present itself; was it on desktop or mobile? 
What versions/platforms are affected? 
Also, Can you please provide detailed reproduction steps?
Flags: needinfo?(joseenrique.alvarezfernandez)
(Reporter)

Comment 6

4 years ago
Hi all

As this was reported long ago, I didn't check it again due to it's low priority. 

I've seen today that this bug is no longer reproducable as YouTube app no longer has the option to "Connect your accounts"

Time ago, if you opened the app, tap on the three bar icon on the up left side, then tap on the wheel icon, there was an option there "Connect your accounts" that allowed you connec your Facebook & Twitter accounts.

Right now, this option is not available so closing this bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(joseenrique.alvarezfernandez)
Resolution: --- → FIXED

Comment 7

4 years ago
Created attachment 8581555 [details]
2015-03-23-19-10-39.png

Hi Jose-,

The option to "Connect your accounts" still exist in Youtube app.Check the screenshot in the attachment.
Flags: needinfo?(joseenrique.alvarezfernandez)

Comment 8

4 years ago
(In reply to jingmei.zhang from comment #7)
Hi Jose-,

But now only twitter app is allowed to be connected.Perhaps twitter can be connected successfully(I do not have a twitter accounts,so I can not confirm this,but see from bug985663,it seems to be so),can you help to check?

Comment 9

4 years ago
Hi Michael,

For third app Youtube,there is another issue as described in Bug 985715 - [B2G][Youtube] The user is unable to check the boxes under 'Share your public activity to connected accounts',can you help to track?
Flags: needinfo?(mellis)
(Reporter)

Comment 10

4 years ago
Hi 

Yes you're right. It's still appears although you have to be logged in using your account to make it appear. Sorry, I missed that step

Steps to reproduce:
- Open YoutTube app
- Tap on the 3 bars icon on the upper left side of the screen
- Tap on sign in and login with your Google account
- Tap on the Wheel Icon
- Scroll down until you see "Connect your accounts"
- Tap on the "Connect" button next to the Twitter Logo
- Wait until the login & authorize page from Twitter appears. Introduce your Twitter login info and authorize the app. You will be redirected back
- You may see that the option to connect your Twitter account still appears and seems that nothing has happened
The result is that the Twitter account (the only one that appears now)option is not working properly as is not connecting your Twitter account. If you you to the YouTube desktop version (on a PC) and check your settings you will see that the Twitter option to connect is still available and, therefore, the connection of the account did not work properly from the mobile

Thanks
Flags: needinfo?(joseenrique.alvarezfernandez)

Comment 11

4 years ago
Thank you for providing the additional reproduction step.  I tested this bug today on 1.3 & 2.0.  Although the YouTube app does not indicate that the user has successfully Connected to their Twitter Account through the YouTube settings, if the user completes the login process and taps again on the "connect" button for Twitter, They are taken to a screen where they can now "log out" of the twitter account.  This indicates that YouTube is successfully connecting to Twitter the account. 

We will bring this issue up with YouTube and see if we can get the "connect" button to change state after login is completed.
Flags: needinfo?(mellis)

Comment 12

4 years ago
Please ping YT and see if they can update the "connect" button to change state after the user completes the log in process
Status: RESOLVED → REOPENED
Flags: needinfo?(hkirschner)
Resolution: FIXED → ---
Whiteboard: [sprd387380]
(Assignee)

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Flags: needinfo?(hkirschner)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.