some svg path are missing to draw

VERIFIED FIXED

Status

()

Core
SVG
VERIFIED FIXED
4 years ago
2 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

28 Branch
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8488602 [details]
screenshot

This is regressed since Firefox28.

Steps To Reproduce:
1. Open http://24ways.org/2013/animating-vectors-with-svg/

Actual Results:
some svg path are missing

Expected Results:
All svg path should draw.
(Reporter)

Comment 1

4 years ago
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/92f737230338
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131117170238
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/af0931327e49
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131117173035
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=92f737230338&tochange=af0931327e49
(Reporter)

Comment 2

4 years ago
In loval build 
Last Good: a08baab2e6f3
First Bad: 4f086025350f
Triggered by:
4f086025350f	Jonathan Watt — Bug 930577 - Convert much of the SVG code for calculating path lengths and position at an offset along a path to Moz2D. r=heycam
Blocks: 930577
Seems to draw now.
(Reporter)

Comment 4

3 years ago
Created attachment 8588331 [details]
screenshot comparison btw Nightly40, Firefox37, IE11 and Chrom41

Improved. But, still broken.

Comment 5

3 years ago
This works for me with the patch from bug 1134549 applied.
Depends on: 1134549
(Reporter)

Comment 6

2 years ago
I can still reproduce the problem on Latest Nightly48.0a1[1] if HWA off, but not HWA on

[1]
https://hg.mozilla.org/mozilla-central/rev/b6683e141c47c022598c0caac3ea8ba8c6236d42
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0 ID:20160407030234
(Reporter)

Updated

2 years ago
status-firefox32: affected → ---
status-firefox33: affected → ---
status-firefox34: affected → ---
status-firefox35: affected → ---
status-firefox48: --- → affected
status-firefox-esr31: affected → ---

Comment 7

2 years ago
I can no longer reproduce on Ubuntu 15.10 after applying the patch from bug 1134549, just recently pushed in https://hg.mozilla.org/mozilla-central/rev/3e73fc0dfb01
(Reporter)

Comment 8

2 years ago
confirmed
I cannot reproduce the problem on Nightly[1] with/without HWA.

[1]
https://hg.mozilla.org/mozilla-central/rev/564b225d553547fe4aa9a1039278f695c9507db9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0 ID:20160413030239
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox48: affected → fixed
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → FIXED
QA Whiteboard: [good first verify]

Comment 9

2 years ago
I reproduced the initial issue on old Nightly 35.0a1 (2014-09-12).
I verified that the issue is fixed using Firefox-48.0b5 on Windows 10 x64, Windows 7 x64, Ubuntu 14.04, x32, Mac 10.10.
Thanks Cipri for testing!
Changing tracking flag for 48 to verified and closing this bug as Verified Fixed.
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify]
status-firefox48: fixed → verified
You need to log in before you can comment on or make changes to this bug.