Closed Bug 1066604 Opened 5 years ago Closed 5 years ago

Can not install web apps; " A coding exception was thrown and uncaught in a Task. Gecko: Full message: TypeError: aMessage.app.updateManifest is undefined"

Categories

(Firefox for Android :: Web Apps (PWAs), defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox35 --- verified
fennec 35+ ---

People

(Reporter: cos_flaviu, Assigned: myk)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

Environment: 
Device: Google Nexus 7 (Android 4.4.4);
Build: Nightly 35.0a1 (2014-09-12);

Steps to reproduce:
1. Go to https://marketplace.firefox.com/
2. Tap on the 'Free' button on any app to install it. 

Expected result:
The installation setup  pops up.

Actual result:
The trobber is weirdly spinning and after a few seconds the 'Sorry, you are currently offline. Please try again later' error message is displayed.
I see this too on Nightly (09/12)

E/GeckoConsole( 4756): [iframe-install] Received message: {"name":"install-package","data":{"product":{"author":"GameMix","device_types":["desktop","android-mobile","android-tablet","firefoxos"],"icons":{"32":"https://marketplace.cdn.mozilla.net/img/uploads/addon_icons/503/503911-32.png?modified=1b002702","64":"https://marketplace.cdn.mozilla.net/img/uploads/addon_icons/503/503911-64.png?modified=1b002702"},"id":503911,"is_packaged":false,"manifest_url":"http://www.astroalpaca.com/firefox.webapp","name":"AstroAlpaca","payment_required":false,"premium_type":"free","price":null,"price_locale":null,"ratings":{"count":21,"average":4.4286},"slug":"astroalpaca","user":{"purchased":false,"installed":false,"developed":false},"receipt_required":false},"opt":{}}}
E/GeckoConsole( 4756): [iframe-install] Received post message to install-package from https://marketplace.firefox.com
I/Gecko   ( 4756): *************************
I/Gecko   ( 4756): A coding exception was thrown and uncaught in a Task.
I/Gecko   ( 4756): 
I/Gecko   ( 4756): Full message: TypeError: aMessage.app.updateManifest is undefined
I/Gecko   ( 4756): Full stack: this.WebappManager._installApk/<@resource://gre/modules/WebappManager.jsm:105:1
I/Gecko   ( 4756): TaskImpl_run@resource://gre/modules/Task.jsm:314:40
I/Gecko   ( 4756): TaskImpl@resource://gre/modules/Task.jsm:275:3
I/Gecko   ( 4756): createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:249:14
I/Gecko   ( 4756): Task_spawn@resource://gre/modules/Task.jsm:164:12
I/Gecko   ( 4756): this.WebappManager._installApk@resource://gre/modules/WebappManager.jsm:94:1
I/Gecko   ( 4756): this.WebappManager.install@resource://gre/modules/WebappManager.jsm:81:5
I/Gecko   ( 4756): BrowserApp.observe@chrome://browser/content/browser.js:1710:1
I/Gecko   ( 4756): this.DOMApplicationRegistry.receiveMessage/<@resource://gre/modules/Webapps.jsm:1080:1
I/Gecko   ( 4756): Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:865:23
I/Gecko   ( 4756): this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:744:7
I/Gecko   ( 4756): 
I/Gecko   ( 4756): *************************
I/GeckoWebappUninstallListener( 3935): Package is being replaced; ignoring removal intent
Flags: needinfo?(myk)
I see the same thing on testmanifest.com on attempt to install

> Full message: TypeError: aMessage.app.updateManifest is undefined
tracking-fennec: --- → ?
Summary: Can not install web apps; 'Sorry, you are currently offline' error message is displayed. → Can not install web apps; " A coding exception was thrown and uncaught in a Task. Gecko: Full message: TypeError: aMessage.app.updateManifest is undefined"
Last good build: 2014-09-10;
First bad build: 2014-09-11;

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=152ef25e89ae&tochange=bc7deafdac4b
My bet is on the bug to restrict the profile for guest mode over in bug 1058150 which is in that range. CC'ing Wes
Flags: needinfo?(myk)
Last good revision: 02fbb6ada9cb
First bad revision: bc7deafdac4b
Pushlog:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=02fbb6ada9cb&tochange=bc7deafdac4b

bf52063ed95f	Wes Johnston — Bug 1058150 - Use restricted profiles for guest mode. r=mfinkle
Blocks: 1058150
I initially thought the fix in bug 1066671 would fix this too, but it didn't.
The code on line 105 tries to access | aMessage.app.updateManifest.name; | but the debuggger shows that the aMessage.app object has neither a manifest or an updateManifest.
Duplicate of this bug: 1067526
Myk or Marco, you have any idea what changed here? AFAICT, the manifest properties have been removed from the WebApps:Install methods that are passed through the cpmm here:

http://mxr.mozilla.org/mozilla-central/source/dom/apps/Webapps.js#136

hg history isn't giving me the answers I want, so I thought I'd ping.
Flags: needinfo?(myk)
Flags: needinfo?(mar.castelluccio)
Duplicate of this bug: 1068253
Ahh. This is a regression from Bug 960584
Depends on: 960584
Indeed!  So I backed out bug 960584, which will fix this bug once the backout changeset merges from fx-team to central.
Flags: needinfo?(myk)
Flags: needinfo?(mar.castelluccio)
Backout merged, resolving this bug:

https://hg.mozilla.org/mozilla-central/rev/0d1299b49f17
Assignee: nobody → myk
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
tracking-fennec: ? → 35+
Status: RESOLVED → VERIFIED
Does this has test coverage so it doesn't break again?
Flags: qe-verify+
Flags: in-testsuite?
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.