All users were logged out of Bugzilla on October 13th, 2018

Cannot launch the cardivew after doing a longpress -> open in a new tab

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: etienne, Assigned: etienne)

Tracking

unspecified
2.1 S5 (26sep)
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
STR:

- go to a website
- long press a link, choose "open in a new tab"
(the new tab opens)
- tap the "..." button
- choose "show windows"

Expected: you see the filtered cardview
Actual: we implode (TypeError: undefined is not a valid URL.)
(Assignee)

Comment 1

4 years ago
Created attachment 8488633 [details] [review]
Gaia PR
Assignee: nobody → etienne
Attachment #8488633 - Flags: review?(dale)
Comment on attachment 8488633 [details] [review]
Gaia PR

Good catch, in general if we have entirely broken functionality like that I would like seeing us bump up the integration coverage, but can take that on in another bug. I like the url :)

merged in: https://github.com/mozilla-b2g/gaia/commit/e5da0e462e51cf7f56963e87deb845f87a3a1cf4
Attachment #8488633 - Flags: review?(dale) → review+

Updated

4 years ago
Duplicate of this bug: 1064979
Sorry, forgot to close
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1065888
Blocks: 1095702
[Blocking Requested - why for this release]: Requesting blocking because uplifting the changes to browser.js will fix both bug 1095702 and bug 1095154.
blocking-b2g: --- → 2.1?
Blocks: 1096512
blocking-b2g: 2.1? → 2.1+
Blocks: 1095154
Please nominate this for Gaia v2.1 uplift when you get a chance.
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Flags: needinfo?(etienne)
Target Milestone: --- → 2.1 S5 (26sep)
I would nominate this for uplift now, but I believe we need a branch patch due to some v2.1 only patches getting in. It looks like there might only be one patch conflicting it, but a simple approach might be something like: git checkout master apps/system/js/browser.js
(Assignee)

Comment 9

4 years ago
Created attachment 8522302 [details] [review]
Gaia PR for 2.1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: "show windows" feature not working
[Testing completed]: basic web sheet/task manager scenarios
[Risk to taking this patch] (and alternatives if risky): low (clear-cut and unit-tested)
[String changes made]: none
Flags: needinfo?(etienne)
Attachment #8522302 - Flags: approval-gaia-v2.1?
Attachment #8522302 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+

Comment 10

4 years ago
Verified the issue is fixed on 2.2 Flame

Web-pages are visible in card view after open a new tab

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141113040205
Gaia: be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko: ab137ddd3746
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"
==================================================================
Leaving verifyme for 2.1 patch uplift.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: affected → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
status-b2g-v2.1: verified → affected
status-b2g-v2.2: fixed → verified
This issue seems to be working now on 2.1, even though the patch is not uplifted. The cardview feature works properly following STRs on Comment 0.

Device: Flame 2.1 (319mb, KK, Shallow Flash)
BuildID: 20141113001200
Gaia: 569a299ca446f714cd98d5881cc058fd6f6e257b
Gecko: d188e92aa5a6
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Comment on attachment 8522302 [details] [review]
Gaia PR for 2.1

This has failures on the Gaia Try run that will need addressing before it can be merged.
Flags: needinfo?(etienne)
FWIW - it looks like the currently failing integration tests are also failing on b2g34-v2.1. I would not let those stop you, but we should definitely figure out why those tests are failing. The linter errors definitely need to be addressed.
(Assignee)

Comment 14

4 years ago
Just updated the PR.
Travis running (but the Gij issues are indeed reproducible on 2.1)
Flags: needinfo?(etienne)
(Assignee)

Comment 15

4 years ago
Ha. Travis :)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 17

4 years ago
Verify, the issue is fixed on 2.1 
The pages could be opened in "card view"

"Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141117001201
Gaia: 81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko: 3572aa3e6766
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0"
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.