If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Malformed metatag crashes mozilla

VERIFIED WORKSFORME

Status

()

Core
Layout
--
critical
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Daniel Lichtenberger, Assigned: Marc Attinasi)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011024
BuildID:    20011024

The submitted page contains a malformed meta tag which crashes mozilla 20011024
on linux (but not 0.9.5).

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.infosys.tuwien.ac.at
2.
3.

Actual Results:  Mozilla crashes

Expected Results:  It should display the page

A very simple testcase:

<HTML>
<META :->
</HTML>

I'm aware this is not valid html, but it certainly shouldn't crash mozilla. Plus
it is from a real-world-webpage ...
(Reporter)

Comment 1

16 years ago
Created attachment 55048 [details]
Three-liner that crashes mozilla

Comment 2

16 years ago
dup of bug 106527?
Daniel, please retest with an Oct 25 build.  If this crash is gone, this is a
duplicate of bug 106527
(Reporter)

Comment 4

16 years ago
Yes, the crash is gone in the latest build.
Marking WFM per reporter's comment ("Yes, the crash is gone in the latest build").
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: crash
Resolution: --- → WORKSFORME

Comment 6

16 years ago
v 20010225 linux
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.