Fix several regressions in cards view accessibility.

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: yzen, Assigned: yzen)

Tracking

(Blocks: 1 bug, {access})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
After bug 1061324 landed cards view accessibility regressed. Things that need to be done:

* Enable pointer events for cards buttons
* Enable navigation to the app when the preview is activated
* Make sure statusbar is actually invisible
* Make sure notification is actually invisible
(Assignee)

Comment 1

3 years ago
Created attachment 8488772 [details] [review]
Github pull request.
Attachment #8488772 - Flags: review?(zcampbell)
Attachment #8488772 - Flags: review?(alive)
Comment on attachment 8488772 [details] [review]
Github pull request.

Don't think there's problem but still f?=sfoster
Attachment #8488772 - Flags: review?(alive)
Attachment #8488772 - Flags: review+
Attachment #8488772 - Flags: feedback?(sfoster)

Comment 3

3 years ago
Comment on attachment 8488772 [details] [review]
Github pull request.

The test is unusually long and could be prone to intermittents but it runs OK on 
device too so I effectively r+ it, but....

r- on the smallest nit: it needs to also be added to tbpl-manifest.ini so that this test will Gaia-Try run it.  (expect this file will be deprecated before the end of the week but in the meantime we need to do it this way).
Attachment #8488772 - Flags: review?(zcampbell) → review-
(Assignee)

Comment 4

3 years ago
Comment on attachment 8488772 [details] [review]
Github pull request.

Added a test to tbpl manifest.
Attachment #8488772 - Flags: review- → review?(zcampbell)

Comment 5

3 years ago
Comment on attachment 8488772 [details] [review]
Github pull request.

r+ looks good now.
Attachment #8488772 - Flags: review?(zcampbell) → review+
Comment on attachment 8488772 [details] [review]
Github pull request.

Looks good to me also
Attachment #8488772 - Flags: feedback?(sfoster) → feedback+
(Assignee)

Comment 7

3 years ago
https://github.com/mozilla-b2g/gaia/commit/f4e4858733e19ccfc278b7fe7e01dd7a16fb456b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

3 years ago
Comment on attachment 8488772 [details] [review]
Github pull request.

Cards view accessibility(a11y) was worked on during 2.1 however some new features landed late enough and broke some of the a11y.
[Bug caused by] (feature/regressing bug #): bug 1061324
[User impact] if declined: Cards view would be significantly inaccessible. The users will have several unlabelled buttons, also they won't be able to select apps by clicking on the preview screen.
[Testing completed]: Added substantial gaia ui tests.
[Risk to taking this patch] (and alternatives if risky): Relatively low. Just minor changes to what already been worked on accessibility wise.
[String changes made]: None
Attachment #8488772 - Flags: approval-gaia-v2.1?
Comment on attachment 8488772 [details] [review]
Github pull request.

As far as I can tell bug 1061324 didn't land on 2.1, so we don't have any regression fix to uplift on 2.1 either.
Attachment #8488772 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1-
(In reply to Fabrice Desré [:fabrice] from comment #9)
> Comment on attachment 8488772 [details] [review]
> Github pull request.
> 
> As far as I can tell bug 1061324 didn't land on 2.1, so we don't have any
> regression fix to uplift on 2.1 either.

That's right, the decision was to not uplift, so this patch doesnt need to be there either (in fact wouldn't merge at all). Despite any misgivings I might have about this decision, I'm not going to go ahead and uplift anyway :)
(Assignee)

Updated

3 years ago
Depends on: 1061324
You need to log in before you can comment on or make changes to this bug.