Lightning doesn't display calendar info for authorizing multiple calendars from same service

RESOLVED DUPLICATE of bug 901331

Status

Calendar
General
RESOLVED DUPLICATE of bug 901331
3 years ago
3 years ago

People

(Reporter: Carlin Scott, Unassigned)

Tracking

Lightning 3.3
x86_64
Windows 7

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20140716183446

Steps to reproduce:

1) Enable calendar.network.multirealm
2) Create two network calendars that use OAuth (Google CalDav in my case) but don't log in to save time in reproducing this bug.
3) Right-click on the calendars list and choose "Sync Calendars".

A normal user would do the following to reproduce this bug:
1) Enable calendar.network.multirealm
2) Create two network calendars that use OAuth (Google CalDav in my case)
3) Connect to some spotty internet connection such as a free wifi hotspot that you haven't accepted the EULA for.


Actual results:

Two identical authorization windows with no indication of which one is for which calendar. Theoretically if I could scroll through the displayed URL there would be a difference there but I cannot scroll through it to read the full redirect URL.


Expected results:

The titlebar should display the calendar name or original URL for the calendar

Updated

3 years ago
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 31 → unspecified
(Reporter)

Updated

3 years ago
Version: unspecified → Lightning 3.3

Comment 1

3 years ago
Have you assigned names to the respective calendars? Is caching enabled?
(Reporter)

Comment 2

3 years ago
Yes to both of those questions, assuming caching is enabled with the "offline support" option.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 901331
You need to log in before you can comment on or make changes to this bug.