Closed Bug 1066733 Opened 7 years ago Closed 7 years ago

Debugger-debuggees-20.js has redundant test

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: tromey, Assigned: jimb)

Details

Attachments

(1 file)

Debugger-debuggees-20.js has:

var g3 = newGlobal();           // Created after the Debugger; debuggee.
var g4 = newGlobal();           // Created after the Debugger; not debuggee.

... but then g3 and g4 are treated identically.
A call to dbg.addDebuggee(g3) should be added to make the code
follow the comments.
Assignee: nobody → jimb
Status: NEW → ASSIGNED
Attachment #8488734 - Flags: review?(sphink)
Attachment #8488734 - Flags: feedback?(ttromey)
Comment on attachment 8488734 [details] [diff] [review]
Fix JS Debugger test to add debuggees as intended.

Looks good to me.
Attachment #8488734 - Flags: feedback?(ttromey) → feedback+
Attachment #8488734 - Flags: review?(sphink) → review+
Flags: in-testsuite+
OS: Linux → All
Hardware: x86_64 → All
Target Milestone: --- → mozilla35
https://hg.mozilla.org/mozilla-central/rev/cf7af109d888
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.