Closed Bug 1066775 Opened 5 years ago Closed 5 years ago

WebRTC mochitests fail in many different configs with "Received end of ICE gather candidate"

Categories

(Core :: WebRTC, defect)

35 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35
Tracking Status
firefox32 --- unaffected
firefox33 --- unaffected
firefox34 --- fixed
firefox35 --- fixed

People

(Reporter: sydpolk, Assigned: drno)

Details

Attachments

(3 files)

Attached file Client 1.log
Many configurations running the steeplechase WebRTC tests fail with this:

steeplechase INFO  | {"action":"test_unexpected_fail","message":"Received end of ICE gathering candidate","time":1410543019291,"source_file":"dom/media/tests/mochitest/test_peerConnection_basicAudio.html"}

This was run (in this test) with host1 being linux32 and host2 being linux64:

python /Users/mozilla/jenkins/workspace/nightly-ubuntu14_32-ubuntu14_64/steeplechase/steeplechase/runsteeplechase.py --binary /home/mozilla/firefoxes/nightly/linux32/firefox/firefox --binary2 /home/mozilla/firefoxes/nightly/linux64/firefox/firefox --save-logs-to /Users/mozilla/jenkins/workspace/nightly-ubuntu14_32-ubuntu14_64/logs --specialpowers-path /home/mozilla/firefoxes/nightly/linux64/tests/steeplechase/specialpowers --prefs-file /home/mozilla/firefoxes/nightly/linux64/tests/steeplechase/prefs_general.js --signalling-server http://172.16.141.52:8080/ --html-manifest /home/mozilla/firefoxes/nightly/linux64/tests/steeplechase/tests/steeplechase.ini --host1 172.16.141.55:20701 --host2 172.16.141.52:20701

Attaching client logs.
Attached file Client 2.log
Nils, this is the issue I filed as you were leaving on vacation.
Flags: needinfo?(drno)
Thanks Syd. I actually don't need to see machines which reproduced the problem. I already know what is going on.
Flags: needinfo?(drno)
Turns out that ICE gathering is slower in real world scenarios like steeplechase then I was hoping. Lets remove the check for now.

Try run: https://tbpl.mozilla.org/?tree=Try&rev=da4c92b5aa80
Attachment #8494693 - Flags: review?(spolk)
Comment on attachment 8494693 [details] [diff] [review]
bug_1066775_fix_end_of_gathering.patch

Review of attachment 8494693 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good. You are removing a test. It is likely to be too slow in a VM environment. Removing it seems safe.
Attachment #8494693 - Flags: review?(spolk) → review+
Keywords: checkin-needed
Reminder to request uplift once settled in.
Flags: needinfo?(drno)
https://hg.mozilla.org/mozilla-central/rev/ecfe7d352a03
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Comment on attachment 8494693 [details] [diff] [review]
bug_1066775_fix_end_of_gathering.patch

Approval Request Comment
[Feature/regressing bug #]: This problem got introduced recently by bug 1041832 and got uplifted by the release train.
[User impact if declined]: If not uplifted our steeplechase tests will continue to show intermittent failures.
[Describe test coverage new/current, TBPL]: This only takes tests steps out which were too aggressive (to optimistic regarding the timing in the network).
[Risks and why]: No risks as we only take out test checkpoints.
[String/UUID change made/needed]: n/a
Attachment #8494693 - Flags: approval-mozilla-aurora?
Flags: needinfo?(drno)
Comment on attachment 8494693 [details] [diff] [review]
bug_1066775_fix_end_of_gathering.patch

Test only fix. Aurora+
Attachment #8494693 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.