Statusbar icons disappear in utility tray when light themed app is in foreground

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mikehenrty, Assigned: apastor)

Tracking

({polish})

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)
polish
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

STR:

1.) Open settings app
2.) Open Utility Tray

Actual Result:
Statusbar icons remain dark, and so are hard to see with utility tray open.

Expected Result:
Statusbar icons turn light so that they show up with the utility tray.
Alberto, you've done some statubar work recently, can you take a look here?
Flags: needinfo?(apastor)
(Assignee)

Comment 2

4 years ago
Sure thing, I'll take a look
Assignee: nobody → apastor
Flags: needinfo?(apastor)
(Assignee)

Comment 3

4 years ago
[Blocking Requested - why for this release]: Broken feature. The statusbar icons are not visible with the utility tray open on some apps
blocking-b2g: --- → 2.1?
(Assignee)

Comment 4

4 years ago
Created attachment 8489314 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24045
Attachment #8489314 - Flags: review?(mhenretty)
Broken feature.
blocking-b2g: 2.1? → 2.1+
Comment on attachment 8489314 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24045

Nice fix.
Attachment #8489314 - Flags: review?(mhenretty) → review+
(Assignee)

Comment 7

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/25616a8cf9ab2cc98cb5e4d5323a3537a96d14a2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S5 (26sep)
Please request Gaia v2.1 approval on this patch when you get a chance.
Flags: needinfo?(apastor)
(Assignee)

Comment 9

4 years ago
Comment on attachment 8489314 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24045

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: Statusbar icons hardly visible in some apps
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): Low risk. CSS only
[String changes made]: -
Attachment #8489314 - Flags: approval-gaia-v2.1?(fabrice)
Flags: needinfo?(apastor)
Attachment #8489314 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Issue verified as fixed on Flame 2.1 and Flame 2.2

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Statusbar icons change from dark on light to light on dark when utility tray is pulled down in light themed apps.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Comment 12

4 years ago
Created attachment 8508630 [details]
TESTS: Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/25361/files
Attachment #8508630 - Flags: review?(mhenretty)
Comment on attachment 8508630 [details]
TESTS: Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/25361/files

Test looks good! I reverted the patch for this bug, re-ran, and it indeed fails, so its a good test.
Attachment #8508630 - Flags: review?(mhenretty) → review+
You need to log in before you can comment on or make changes to this bug.