JavascriptException: JavascriptException: TypeError: data.type is null at: app://system.gaiamobile.org/js/statusbar.js line: 934

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Anshul, Assigned: kgrandon)

Tracking

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

(Whiteboard: [caf priority: p2][CR 725360][systemsfe])

(Reporter)

Description

3 years ago
[Blocking Requested - why for this release]:

I am seeing this exception during our unit test run on FFOS 2.1. This error is causing the unit test to fail.
blocking-b2g: 2.1? → 2.1+
Whiteboard: [systemsfe]

Updated

3 years ago
Component: Gaia → Gaia::System
(Assignee)

Updated

3 years ago
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.1 S5 (26sep)
(Assignee)

Comment 1

3 years ago
I was unable to reproduce this on v2.1, and the unit test suite passes successfully for me. Also it seems like the code has been updated recently, so this may just work now.

Anshul - Are you still seeing this? Can you provide a perma-link to the line of code that's failing as it seems to have been moved/updated recently.

Marking 2.1 and 2.2 as fixed based on current information.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.1: --- → fixed
status-b2g-v2.2: --- → fixed
Flags: needinfo?(anshulj)
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

3 years ago
Kevin, will reopen and provide the new line number if I see the issue happening again.
Flags: needinfo?(anshulj)

Updated

3 years ago
Whiteboard: [systemsfe] → [CR 725360][systemsfe]

Updated

3 years ago
Whiteboard: [CR 725360][systemsfe] → [caf priority: p2][CR 725360][systemsfe]
You need to log in before you can comment on or make changes to this bug.