[Flame][v2.1] Communication app can be deleted

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Build
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: TD, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Long pressing on the homescreen allows you to delete the dialer and messaging apps, with no clear way to get them back without a phone reset.
Once deleted there's no way to get them back. I've installed the v2.1 and I couldn't reproduce it in my Flame. I move it to Gaia::Build because the home screen just receives a flag from the API called "removable". If it is true for an app we add the cross image, in another case, if it is not defined or it is false we won't add the cross icon. Although adding qawanted for checking this issue. Thanks a lot
Component: Gaia::Homescreen → Gaia::Build
Keywords: qawanted
Unable to reproduce this issue on Flame 2.1 with KK base + tinderbox eng build or on Flame 2.1 with JB base + nightly user build.

Test Result: Long pressing over an app icon makes the Homescreen to enter Edit mode, and there isn't an 'X' on Phone or Messages apps that would allow their deletion to occur.

Device: Flame
BuildID: 20140912023307
Gaia: ee335e6340dab596239d335bb571b732775dc84e
Gecko: 48c37c8442cb
Version: 34.0a2 (2.1)
Firmware: v165
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Device: Flame
BuildID: 20140912000203
Gaia: 7fe8807b384e1867fa4322f49a1310126fc5a849
Gecko: 1d4b0fc511dc
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA-Wanted is unable to reproduce -  please feel free to re-tag us if this bug gets updated with any additional information that might assist a repro.
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Thomas - this appears to be a problem with your particular build config. Can you describe where you got your build from, and how it's configured?

By design we should not allow you to delete these, and since we're unable to reproduce this currently, closing as worksforme. Please provide additional information and we will revisit this though.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(tdaede)
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

4 years ago
I do builds from source. Config step:
BRANCH=v2.1 ./config.sh flame

.userconfig contents:
export CC=/opt/gcc-4.6.4/bin/gcc
export CXX=/opt/gcc-4.6.4/bin/g++
export BRANCH=v2.0
export MOZILLA_OFFICIAL=1
export PRODUCTION=1

Flashing is done with flash.sh.

I would like my build to match the nightly builds, am I missing anything? I'd like to update the wiki if this isn't sufficient.
Flags: needinfo?(tdaede)
You need to log in before you can comment on or make changes to this bug.