New JS errors/warnings should scroll into view

RESOLVED WONTFIX

Status

Toolkit Graveyard
Error Console
--
enhancement
RESOLVED WONTFIX
16 years ago
a year ago

People

(Reporter: neil@parkwaycc.co.uk, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
Using Build ID: 2001102309
Steps to reproduce problem:
1. Open the JS console
2. Evaluate # or @ (or some other error) ten times or so

Actual results: latest error is only visible on last > first sort order
                (and then only if you haven't scrolled the list).

Expected results: latest error should always be visible, scrolled to bottom or top.

Updated

16 years ago
Severity: normal → enhancement
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Updated

15 years ago
OS: Windows 95 → All
Hardware: PC → All

Comment 1

12 years ago
Scrolling the new errors into view automatically might not be the desired behavior: consider the situation when the new messages keep coming at a regular intervals and you're interested in one particular message.
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
Assignee: hewitt → nobody
Status: ASSIGNED → NEW
QA Contact: jrgmorrison → error-console
Target Milestone: Future → ---

Updated

8 years ago
Depends on: 490886

Updated

8 years ago
Blocks: 490886
No longer depends on: 490886

Updated

7 years ago
Component: Error Console → Error Console
Product: SeaMonkey → Toolkit
QA Contact: error-console → error.console

Comment 2

7 years ago
Just looked and I believe that this is actually the current behavior for errors generated on the page code, but can confirm that the described problem occurs for output from evaluated code.


Personally I'd like it to be consistently that if you are currently scrolled to the extreme top / bottom then as new messages arrive you *stay* at the extreme top / bottom. 

Alternatively, if you have scrolled away from these extremes (eg to read one particular message) then the you should 'stick' to the currently visible message(s) when new ones arrive.
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
The Error Console feature was removed entirely from the tree in Bug 1278368 and the bugzilla component is now being removed. We’ve migrated bugs that seem to also affect the Browser Console into the devtools component, please move this over if it was missed.
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
Resolution: --- → WONTFIX
(Assignee)

Updated

a year ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.