Closed Bug 1067005 Opened 10 years ago Closed 10 years ago

[Flame] Merge recovery kk branch from t2m

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
2.2 S3 (9jan)

People

(Reporter: gerard-majax, Assigned: viralwang)

References

Details

(Whiteboard: [systemsfe])

Attachments

(4 files)

T2M has a kk branch that we do not have.
Michael, since it's just pushing a new branch, I cannot do a PR against it. What is the workflow in this case?
Depends on: 1004195
Viral, I'm not able to get a recovery that boots properly using partner's sources: I get a blue screen, and flashes of what looks like a recovery interface, but whith the UI sized down.
Flags: needinfo?(vwang)
Whiteboard: [systemsfe]
Dunno if it's related with comment 4 or not, but I've noticed that the images included in the recovery partition provided by the OEM (on res/img) are bigger than the ones we compile (from librecovery/res/images). For example, icon_error.png is 480 x 854 in the OEM recovery and 320 x 480 in the compiled version.
(In reply to Alexandre LISSY :gerard-majax from comment #4)
> Viral, I'm not able to get a recovery that boots properly using partner's
> sources: I get a blue screen, and flashes of what looks like a recovery
> interface, but whith the UI sized down.

It's weird that I see same blue screen as your description with partner's source only in my first try.
After that, I just find out that I can't boot up successfully after "Reset Phone" (test in 2 different flames with base image v180)
I think we can check it with partner first.
Flags: needinfo?(vwang)
partner provides a new branch foxfone-one-v2.0 with latest build.
It looks normal now but it's not full screen as below:
https://www.copy.com/s/fPBfFTlFvqKf3Mif/IMAG1561.jpg

One possible solution is to ask partner to remove the symlink and put those recovery images with correct resolution on github.
Blocks: 1084041
(In reply to viral [:viralwang] from comment #7)
> partner provides a new branch foxfone-one-v2.0 with latest build.
> It looks normal now but it's not full screen as below:
> https://www.copy.com/s/fPBfFTlFvqKf3Mif/IMAG1561.jpg
> 
> One possible solution is to ask partner to remove the symlink and put those
> recovery images with correct resolution on github.

That does not work for me.

STR:
 0. In bootable/recovery, checkout foxfone-one-v2.0 branch from t2m
 1. rm -rf out/ && ./build.sh
 2. flash new recovery.img
 3. reboot in recovery

Expected:
 Working recovery

Actual:
 Same as comment 4.

I cannot work on bug 1084041 if we are not able to get a working recovery: the one provided by T2M with v188 does not work: unable to mount the sdcard partition.
Flags: needinfo?(vwang)
Sorry for the late reply.
I heard this sdcard issue from Wesly also.
I found the sdcard can not mount properly in v188-1 recovery mode.
$ adb shell df
Filesystem               Size     Used     Free   Blksize
/dev                   452.7M   128.0K   452.6M   4096
/system                354.2M   267.3M    86.8M   4096
/data                    2.0G    37.8M     2.0G   4096

Hi Wesly,
Shall we pass this information to partner already? any feedback we have?
Flags: needinfo?(vwang) → needinfo?(wehuang)
See Also: → 1095380
Looks like I make a mistake in comment 9.

Wesly just show me the "sdcard can not mount" means there should be some error logs showing on screen.
So let me correct my description.
v188-1: sdcard looks fine in recovery mode (no error message in "apply update from sdcard")

Hi Alexandre,

Wesly mentioned the sdcard error comes after flashing boot.img/userdata.img/system.img
comment 8 looks like the error comes with our own recovery.img
Maybe you can help to clarify which is right? (If not, I can try both combinations.)
Thanks!
Flags: needinfo?(wehuang)
(In reply to viral [:viralwang] from comment #10)
> Looks like I make a mistake in comment 9.
> 
> Wesly just show me the "sdcard can not mount" means there should be some
> error logs showing on screen.
> So let me correct my description.
> v188-1: sdcard looks fine in recovery mode (no error message in "apply
> update from sdcard")
> 
> Hi Alexandre,
> 
> Wesly mentioned the sdcard error comes after flashing
> boot.img/userdata.img/system.img
> comment 8 looks like the error comes with our own recovery.img
> Maybe you can help to clarify which is right? (If not, I can try both
> combinations.)
> Thanks!

The error about mounting the sdcard is because we define the external sdcard as the one to be used by librecovery.

But that's a small issue if we can fix building the recovery itself: I'm okay to have to change the sdcard used by librecovery if it's an accepted decision that we expect users to have an external sdcard to apply FOTA packages.
Flags: needinfo?(vwang)
Hi Alexandre,

Sorry for late reply :(
It looks like we can have our own recovery image with different UI
http://pan.baidu.com/s/1pJLoPuF
Is that good to you?
Flags: needinfo?(vwang) → needinfo?(lissyx+mozillians)
I don't care about the UI, I don't know what you all are trying to achieve right now. What I do care about, however, is being able to build my own recovery.
Flags: needinfo?(lissyx+mozillians) → needinfo?(vwang)
Attachment #8537157 - Flags: review?(lissyx+mozillians)
Flags: needinfo?(vwang)
Attachment #8537159 - Flags: review?(lissyx+mozillians)
Attachment #8537155 - Flags: review?(lissyx+mozillians) → review?(mwu)
Attachment #8537157 - Flags: review?(lissyx+mozillians) → review?(mwu)
Attachment #8537159 - Flags: review?(lissyx+mozillians) → review?(mwu)
I'm not a peer so I should not review those, but I'll test and give feedback.
Attachment #8537155 - Flags: feedback+
Attachment #8537157 - Flags: feedback+
Attachment #8537159 - Flags: feedback+
Attached file Sideloading package
Loading the package works on my recovery kk, but it fails to check the properties values. That's strange, because the same code used to work on recovery for JB.

Viral, can you check that we miss nothing (like a /system not mounted, ... ?).

To reproduce, |./build.sh gecko-update-fota| and then sideload with |adb sideload out/target/product/flame/fota/partial/update.zip|
Flags: needinfo?(vwang)
Flags: needinfo?(gsvelto)
Attachment #8537155 - Flags: review?(mwu) → review+
Attachment #8537159 - Flags: review?(mwu) → review+
Comment on attachment 8537157 [details] [review]
update b2g-manifest to build our own recovery image in flame-kk

Do we have a git.mozilla.org mirror for this?

Alternately this can be mirrored to github.com/mozilla-b2g.
(In reply to Michael Wu [:mwu] from comment #19)
> Comment on attachment 8537157 [details] [review]
> update b2g-manifest to build our own recovery image in flame-kk
> 
> Do we have a git.mozilla.org mirror for this?
> 
> Alternately this can be mirrored to github.com/mozilla-b2g.

Hi Michael,

I just figure out we have it mirrored in JB already.
https://github.com/mozilla-b2g/platform_bootable_recovery/tree/foxfone-one

https://github.com/t2m-foxfone/platform_bootable_recovery/tree/foxfone-one-v2.0
I think we need a new branch for the latest KK code from partner
Could you please help on this?

I will update manifest to github.com/mozilla-b2g later.
Thank you.
Flags: needinfo?(mwu)
(In reply to Alexandre LISSY :gerard-majax from comment #18)
> Created attachment 8537233 [details]
> Sideloading package
> 
> Loading the package works on my recovery kk, but it fails to check the
> properties values. That's strange, because the same code used to work on
> recovery for JB.
> 
> Viral, can you check that we miss nothing (like a /system not mounted, ...
> ?).
> 
> To reproduce, |./build.sh gecko-update-fota| and then sideload with |adb
> sideload out/target/product/flame/fota/partial/update.zip|

Hi Alexandre,

It looks like we already do the same recovery image as partner provide.
Not sure if what I can help now :(
(/system should work with /dev/block/platform/msm_sdcc.1/by-name/system /system ext4 ro,seclabel,relatime,data=ordered 0 0)
Flags: needinfo?(vwang)
(In reply to Michael Wu [:mwu] from comment #22)
> Pushed.
> 
> https://github.com/mozilla-b2g/platform_bootable_recovery/tree/foxfone-one-
> v2.0

Hi Michael,

Thank you for your great help.
I already update manifest on attachment 8537157 [details] [review].
Could you please help to review it again?
Thank you :)
Hi Michael,

Update the attachment 8537157 [details] [review] again.
I add remove-project tag in flame-kk.xml.
It will update one file and keep base-kk.xml same.
Thank you!!
Comment on attachment 8537157 [details] [review]
update b2g-manifest to build our own recovery image in flame-kk

Looks good.
Attachment #8537157 - Flags: review?(mwu) → review+
Hi Alexandre,

Sorry for stealing this bug.
Please feel free to let me know if there's anything improper
Thank you.
Keywords: checkin-needed
Assignee: lissyx+mozillians → vwang
(In reply to viral [:viralwang] from comment #26)
> Hi Alexandre,
> 
> Sorry for stealing this bug.
> Please feel free to let me know if there's anything improper
> Thank you.

No problem, all I care is that bugs are fixed :)
Sorry for being late here, I'm testing the patches right now on my Flame.
For what it's worth since this just landed it seems to be working fine for me :-)
Flags: needinfo?(gsvelto)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: