autocomplete in url bar grabbing keyboard

RESOLVED DUPLICATE of bug 81912

Status

RESOLVED DUPLICATE of bug 81912
17 years ago
14 years ago

People

(Reporter: blizzard, Assigned: blizzard)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
One of the biggest complaints that I get is that the autocomplete widget grabs
the keyboard and mouse.  Would it be possible to pop up that widget without
grabbing?  We could just pop down if the parent window lost focus.

What do you guys think?  It's seriously annoying.

Comment 1

17 years ago
Could you clarify the problem?  What are some keyboard cases that are annoying?
 There is already a bug for the autocomplete widget grabbing the mouse, so you
have to click twice to hit another button.  Is that what you mean about the
mouse?  That's bug 66834.
(Assignee)

Comment 2

17 years ago
Well, it's the fact that you can't click on other items and you can't use the
keyboard to change desktops or switch apps while the autocomplete bar is up.

Comment 3

17 years ago
w/o a window manager you don't have this problem ;-(

Comment 4

17 years ago
Yes this is supremely annoying. Often I start to type in a URL, autocomplete
dropdown pops up, and now Meta+Tab won't switch windows for me (my window
manager bind for that function).

Comment 5

17 years ago
Ahhhh, forgive me if I'm wrong
is this bug and bug 81912 related?
(Assignee)

Comment 6

17 years ago
*** Bug 81912 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

17 years ago

*** This bug has been marked as a duplicate of 81912 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.