space gets removed from user-defined header

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Composition
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: g.s, Unassigned)

Tracking

SeaMonkey 2.29 Branch
seamonkey2.39
x86_64
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; FreeBSD amd64; rv:32.0) Gecko/20100101 Firefox/32.0 SeaMonkey/2.29
Build ID: 20140913191616

Steps to reproduce:

Post a test to a test newsgroup with a user-defined header:
user_pref("mail.identity.id5.header.xnoarchive", "X-No-Archive: yes");
user_pref("mail.identity.id5.headers", "xnoarchive");



Actual results:

The user-defined header gets created, but is missing a space after the colon:
X-No-Archive:yes


Expected results:

The space shouldn't have been removed.
The same setting worked in 2.26

Comment 1

2 years ago
@Reporter: Still a problem for you? If “yes”, please contribute a problem related step by step instruction containing every key press and every mouse click how to reproduce your problem (and especially how to create the user defined header) due to <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>    (similar to report in Bug 1139273)
Flags: needinfo?(g.s)
(Reporter)

Comment 2

2 years ago
Does no longer happen in 2.39.
(actually, now there are two spaces after the colon)
Flags: needinfo?(g.s)

Comment 3

2 years ago
(In reply to g.s from comment #2)
Thx!
I did not find an obvious DUP in <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs1067080&sharer_id=41036>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → seamonkey2.39
You need to log in before you can comment on or make changes to this bug.