Visual artifacts while scrolling

RESOLVED DUPLICATE of bug 1063046

Status

()

Firefox for Android
Toolbar
RESOLVED DUPLICATE of bug 1063046
4 years ago
2 years ago

People

(Reporter: tuxor, Unassigned)

Tracking

34 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8489124 [details]
Screenshot_2014-09-14-14-59-20.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140831201947

Steps to reproduce:

Visit http://tovotu.de/tests/firedict/#/manage and scroll (with Aurora 34.0a2, does not occur with 32.0 stable!)


Actual results:

I see random black rectangles spread all over the screen that don't vanish when I stop scrolling. Furthermore scrolling feels sluggish.


Expected results:

Smooth scrolling animation without visual artifacts.
(Reporter)

Updated

4 years ago
OS: Linux → Android
Hardware: x86_64 → ARM

Updated

4 years ago
Component: General → Graphics, Panning and Zooming
(Reporter)

Comment 1

4 years ago
Additional information you might need:

This is running on a Motorola Photon Q with CyanogenMod 11 (AOSP 4.4 without gapps).

The linked page is the ui test page of the webapp FireDict (https://github.com/tuxor1337/firedict) and the problems are also present when installing FireDict from the Firefox Marketplace (https://marketplace.firefox.com/app/firedict) on Aurora for Android (there have to be more than 15 dictionaries or so on the sdcard).

The problems are not present on Firefox 32.0 for Android, Firefox 32.0 for Desktop, Firefox OS Browser (haven't tested more browsers).
(Reporter)

Comment 2

4 years ago
A little testing revealed that this does not happen, if I remove the css property "transform: translateX(0%);" from the section with id #mainArea.

Even if the CSS code turns out to be ... "strange", I think it's still a regression in Aurora. Do you need more information?
If you're responding to me. I don't know anything about this. It would be nice if someone who is monitoring this component could respond, if anyone.
(Reporter)

Comment 4

4 years ago
What I said, was not a direct respond to you. I just wanted to make more precise what this bug is about. I'm going to add more info in a second. Whoever feels responsible may have a look.

I'm now testing with Aurora 34.0a2 /2014-09-22).
(Reporter)

Comment 5

4 years ago
Created attachment 8493622 [details]
Standalone HTML page that causes the issue

This is the maximally reduced html code which causes the bug.
(Reporter)

Comment 6

4 years ago
Created attachment 8493625 [details]
Screenshot_2014-09-23-11-37-10.png

Screenshot of testcase html (see attachment 8493622 [details])
Attachment #8489124 - Attachment is obsolete: true
Able to make anything of this?
Flags: needinfo?(bugmail.mozilla)
Sorry, my bugmail settings apparently changed themselves so i don't get mail for unconfirmed bugs and i didn't see this bug.

That being said i cannot reproduce the behavior in the latest Aurora build so it was quite likely fixed by bug 1063046 which was just uplifted to Aurora a couple of days ago and had similar symptoms. I'm going to dupe this bug to that one but please reopen it if you still see this issue on latest builds.

And thanks for taking the time to make a reduced test case!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(bugmail.mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1063046
You need to log in before you can comment on or make changes to this bug.