Closed Bug 1067132 Opened 7 years ago Closed 7 years ago

[e10s] Unable to open Web Console when e10s is enabled

Categories

(DevTools :: Console, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(e10sm3+)

RESOLVED FIXED
Tracking Status
e10s m3+ ---

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Steps To Reproduce:
Steps To Reproduce:
1. Enable e10s
2. Attempt to open Web Console


Regression window(fx)
Good:
https://hg.mozilla.org/integration/fx-team/rev/1e0e069b5cc7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140912150609
Bad:
https://hg.mozilla.org/integration/fx-team/rev/a6d02cff43d3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140912201609
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=1e0e069b5cc7&tochange=a6d02cff43d3

Suspect: Bug 1037235
Blocks: 1037235
tracking-e10s: --- → ?
The developer console does indeed fail to open (both in "New e10s window", or while e10s is enabled by default).

The browser console displays several error messages when trying to open the when one tries to open the dev console (ie. by pressing F12). The browser console appears as a completely blank window/sidebar (depending on last open configuration) and can not be closed.

See the generated error messages in the browser control in the attachment (note: the browser console needs to be opened from a non-e10s window, as current e10s implementation fails to open the browser console altogether from an e10s window - see bug 1067120).
I can confirm that after disabling e10s (in Settings) and restarting Nightly, the DevTools show up again.
Duplicate of this bug: 1067613
Duplicate of this bug: 1067439
Summary: [e10s] Web Console is empty → [e10s] Unable to open Web Console when e10s is enabled
Duplicate of this bug: 1067330
fixed by backout
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.