nsIXULAppInfo::ID fails in content process.

RESOLVED FIXED in mozilla35

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: markh, Assigned: markh)

Tracking

unspecified
mozilla35
Points:
2
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [e10s])

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

5 years ago
+++ This bug was initially created as a clone of Bug #886903 +++

The file addon-sdk/source/modules/system/XulApp.js makes extensive use of nsIXULAppInfo::ID().  Devtools makes use of this module, and this fails when e10s is enabled as it imports the module in the content process, and nsIXULAppInfo::ID fails with NS_ERROR_NOT_AVAILABLE in that context.

While it is probably possible to fix that for the devtools specific case, it seems reasonable that content-process code might want to know the ID of the app - hence this bug.

Bug 886903 sent more AppInfo data to the child process, but the "ID" of the app wasn't covered.  This patch is almost identical to the one there, marshaling this ID to the child process so it can return it.
Attachment #8489218 - Flags: review?(josh)
Attachment #8489218 - Flags: review?(josh) → review+

Updated

5 years ago
Component: Embedding: GRE Core → DOM: Content Processes
Want to make this do the vendor property as well?
Assignee

Comment 2

5 years ago
(In reply to Josh Matthews [:jdm] from comment #1)
> Want to make this do the vendor property as well?

Yeah, good idea.
Attachment #8489218 - Attachment is obsolete: true
Attachment #8489706 - Flags: review?(josh)
Assignee

Updated

5 years ago
Duplicate of this bug: 1061873
Attachment #8489706 - Flags: review?(josh) → review+
Assignee

Comment 4

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/c45f715f529c
Status: NEW → ASSIGNED
Points: --- → 2
Flags: qe-verify-
Flags: firefox-backlog+
sorry had to back this out for test failures like https://tbpl.mozilla.org/php/getParsedLog.php?id=48355185&tree=Fx-Team
Assignee

Updated

5 years ago
Depends on: 1070810
Assignee

Comment 6

5 years ago
So this is really blocked by bug 902165, and I'll mark bug 1070810 as invalid.
Depends on: 902165
No longer depends on: 1070810
Iteration: --- → 35.2
https://hg.mozilla.org/mozilla-central/rev/7792d7f25f1e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
You need to log in before you can comment on or make changes to this bug.