Closed Bug 1067243 Opened 5 years ago Closed 5 years ago

[Keyboard][Text Selection] Selection carets remain after leaving address bar editing mode

Categories

(Core :: Selection, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED FIXED
mozilla36

People

(Reporter: Omega, Assigned: pchang)

References

Details

Attachments

(1 file, 2 obsolete files)

[Steps To Reproduce]
1. In browser, go to any page (http://m.bbc.com in this case)
2. Tap address bar. (The address will be all selected by default.)
3. Tap outside to leave address bar editing mode.
4. Scroll the page.

[Actual Result]
Touch carets of address bar remain there.

[Expected Result]
Touch carets of address bar should disappear.

Device: Flame
OS Version: 2.2.0.0-prerelease
Platform Version: 35.0a1
Build Identifier: 20140908160203
Git Commit Info: 2014-09-13 17:51:21 (0f45989d)
Priority: -- → P1
After checking, this issue is related to selection  caret.
The possible solution is trying to change the zindex of selection caret.
Summary: [Keyboard][Text Selection] Touch carets remain after leaving address bar editing mode → [Keyboard][Text Selection] Selection carets remain after leaving address bar editing mode
Assignee: nobody → pchang
Attached patch WIP (obsolete) — Splinter Review
Refine the selection reason matching logic to toggle the visibility of selection carets.
Attachment #8495767 - Flags: review?(roc)
Comment on attachment 8495767 [details] [diff] [review]
WIP

Review of attachment 8495767 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/base/SelectionCarets.cpp
@@ +857,5 @@
>    }
> +  if (!aReason ||
> +      aReason & nsISelectionListener::DRAG_REASON ||
> +      aReason & nsISelectionListener::KEYPRESS_REASON ||
> +      aReason & nsISelectionListener::MOUSEDOWN_REASON) {

Write this as

!aReason || (aReasion & (nsISelectionListener::DRAG_REASON | nsISelectionListener::KEYPRESS_REASON | nsISelectionListener::MOUSEDOWN_REASON))
Attachment #8495767 - Flags: review?(roc) → review+
Attached patch bug-1067243.patch (obsolete) — Splinter Review
Address reviewer's comment.
Attachment #8495767 - Attachment is obsolete: true
Attachment #8504524 - Flags: review+
Fix the build break because the wrong variable.

And the following is the new try.
https://tbpl.mozilla.org/?tree=Try&rev=66aee079a8aa
Attachment #8504524 - Attachment is obsolete: true
Attachment #8504556 - Flags: review+
(In reply to peter chang[:pchang][:peter] from comment #6)
> Created attachment 8504556 [details] [diff] [review]
> bug-1067243.patch
> 
> Fix the build break because the wrong variable.
> 
> And the following is the new try.
> https://tbpl.mozilla.org/?tree=Try&rev=66aee079a8aa

From the test link, the failed items are not related to my patch and they also fails in othes' try run.
Keywords: checkin-needed
Duplicate of this bug: 1082413
https://hg.mozilla.org/mozilla-central/rev/fff0b523cfc4
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.