Need treeherder equivalent to talos compare

RESOLVED DUPLICATE of bug 1142680

Status

Tree Management
Treeherder
P4
normal
RESOLVED DUPLICATE of bug 1142680
4 years ago
3 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({regression})

Details

(URL)

Comment hidden (empty)
(Reporter)

Updated

4 years ago
Keywords: regression
Not sure if the comparison stuff is already implemented somewhere else but the following links are what people currently use most:
* http://compare-talos.mattn.ca/ (uses graph server API)
* http://compare-talos.mattn.ca/dev/ (uses Datazilla API so it handles PGO/non-PGO split)
(Reporter)

Comment 2

3 years ago
Ah thank you for the links.

TBPL links to:
http://perf.snarkfest.net/compare-talos/index.html?oldRevs=0391a971e401&newRev=86f9d0128ccf&submit=true

Are they preferred over that?
(Reporter)

Updated

3 years ago
Priority: P3 → P4
(In reply to Ed Morley [:edmorley] from comment #2)
> TBPL links to:
> http://perf.snarkfest.net/compare-talos/index.html?oldRevs=0391a971e401&newRev=86f9d0128ccf&submit=true
> 
> Are they preferred over that?

Yes, I just never got around to getting TBPL changed. Most people are using my version since it's more actively maintained. I've been waiting to reply until I set the site up on paas. I'm now done this on the production paas at https://compare-talos.paas.mozilla.org/ but the DNS entry isn't setup yet (filing a bug now).
Now that bug 1137982 is resolved, the ideal URL IMO would be:
> https://compare-talos.paas.mozilla.org/?oldBranch=Firefox&oldRevs=0391a971e401&newBranch=Firefox&newRev=86f9d0128ccf&submit=true
where the branch parameters are the ones that TBPL used (since that's what datazilla uses). I could add a mapping in compare-talos for values which are different if treeherder doesn't already know about the old names.
(Reporter)

Comment 5

3 years ago
(In reply to Matthew N. [:MattN] from comment #4)
> I could add a mapping in compare-talos for values which are
> different if treeherder doesn't already know about the old names.

The old branch names are now thankfully not used anywhere (they were unique to TBPL/datazilla). Treeherder uses the repo name, like buildbot :-)
Unfortunately Datazilla copied them from TBPL though so unless we fix that I'll need a mapping.
(Reporter)

Updated

3 years ago
No longer blocks: 1059400
(Reporter)

Updated

3 years ago
Summary: Need treeherder equivalent to talos compare (or else links to Datazilla comparison) → Need treeherder equivalent to talos compare
I filed bug 1142680 not knowing about this bug. Let's track this there as it has a bit more context / info.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1142680
You need to log in before you can comment on or make changes to this bug.