Firefox 32.0.1 changes keyboard layout on password input field getting focus on OSX 10.9.4

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: tomolas, Unassigned)

Tracking

32 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8489281 [details]
Screen Shot 2014-09-15 at 11.48.48.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140911151253

Steps to reproduce:

I have more than 1 keyboard layouts (English - US, Slovak). English is my default layout.


Actual results:

With English layout selected I go to any page containing a password input field. When the password input gets focus (is being selected) the keyboard layout is being changed to Slovak. English layout becomes un-selectable at os level.


Expected results:

Keyboard layout should not be changed.
(Reporter)

Comment 2

4 years ago
Thank you for the link. 
One of the answers worked for me.
Very strangely, disabling all (I have just 2) extensions and restarting Firefox worked. Afterwards I was able to enable extensions back and the problem did not reappear.
your problem is now gone ?
(Reporter)

Comment 4

4 years ago
Yes. Thank you for the link once again. 
I found answer on another page linked from the page you provided (answer is here: http://apple.stackexchange.com/a/128157)
Seems to be more of a osx problem affecting Chrome as well as Firefox.
Nevertheless it's a strange behavior that popped up after I installed a new version of Firefox.
thanks, i will mark this bug wfm.
anyway, thanks for the bug report !
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.