[Loop] The sound is not switched off once the fall back mechanism is shown

VERIFIED FIXED

Status

Firefox OS
Gaia::Loop
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mbarone, Assigned: jaoo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile app])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Device: Flame
Build: v2.0 with kk v180 (gecko-2d2ca12 gaia-7edd3b0)
Loop version: c28eaef

STR
1. Create a new contact introducing a phone number. Make sure that the contact phone number is not a loop user.
2. Call this contact (voice or video) to generate the fall back mechanism.

ACTUAL RESULT
The fall back mechanism is shown and the user can share the URL by SMS. The problem is that the app starts with a sound (similar when the user is trying to establish a call). Is not possible to power-off the sound until you kill the Loop app.

EXPECTED RESULT
The app must show the attention screen and start ringing, but once the app shows the window to share the URL, the sound should be off.
(Reporter)

Updated

4 years ago
Summary: [Loop] The sound enter in a loop until you kill the app when the user share a URL → [Loop] The sound is not switched off once the fall back mechanism is shown
(Assignee)

Updated

4 years ago
Assignee: nobody → josea.olivera
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
(Assignee)

Comment 1

4 years ago
Created attachment 8491675 [details] [review]
Pointer to Github PR https://github.com/mozilla-b2g/firefoxos-loop-client/pull/123
Attachment #8491675 - Flags: review?(borja.bugzilla)
Comment on attachment 8491675 [details] [review]
Pointer to Github PR https://github.com/mozilla-b2g/firefoxos-loop-client/pull/123

R+. Take a look to the comment in GH!
Attachment #8491675 - Flags: review?(borja.bugzilla) → review+
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

4 years ago
Tested with Flame (v2.0 kk v180)
Gecko-9362b48.Gaia-6449cc3
Loop version 041ff17
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.