Closed Bug 1067311 Opened 6 years ago Closed 6 years ago

Crash in gfxSurfaceDrawable::DrawWithSamplingRect(gfxContext*, gfxRect const&, gfxRect const&, bool, GraphicsFilter const&, double)

Categories

(Core :: Graphics, defect)

x86
All
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla35
Tracking Status
firefox34 --- unaffected
firefox35 + verified

People

(Reporter: johnp, Assigned: mattwoodrow)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

Keywords: crash, regression
Blocking the bug that introduced this code into central yesterday.
Blocks: 1044702
Crash Signature: [@ memcpy | gfxSurfaceDrawable::DrawWithSamplingRect(gfxContext*, gfxRect const&, gfxRect const&, bool, GraphicsFilter const&, double)] → [@ gfxSurfaceDrawable::DrawWithSamplingRect(gfxContext*, gfxRect const&, gfxRect const&, bool, GraphicsFilter const&, double)]
OS: Windows 8.1 → All
Hardware: x86_64 → x86
Status: UNCONFIRMED → NEW
Crash Signature: [@ gfxSurfaceDrawable::DrawWithSamplingRect(gfxContext*, gfxRect const&, gfxRect const&, bool, GraphicsFilter const&, double)] → [@ gfxSurfaceDrawable::DrawWithSamplingRect(gfxContext*, gfxRect const&, gfxRect const&, bool, GraphicsFilter const&, double)] [@ memcpy | gfxSurfaceDrawable::DrawWithSamplingRect(gfxContext*, gfxRect const&, gfxRect const&, bool, GraphicsFilter const&, …
Ever confirmed: true
Adding https://crash-stats.mozilla.com/report/list?signature=gfxSurfaceDrawable%3A%3ADrawInternal%28gfxContext%2A%2C%20gfxRect%20const%26%2C%20mozilla%3A%3Agfx%3A%3AIntRectTyped%3Cmozilla%3A%3Agfx%3A%3AUnknownUnits%3E%20const%26%2C%20bool%2C%20GraphicsFilter%20const%26%2C%20double%2C%20gfxMatrix%20const%26%29 which I'm pretty sure is caused by the same thing.


I somewhat suspect that https://crash-stats.mozilla.com/report/list?signature=%400x0%20%7C%20gfxUtils%3A%3ADrawPixelSnapped%28gfxContext%2A%2C%20gfxDrawable%2A%2C%20gfxSize%20const%26%2C%20mozilla%3A%3Aimage%3A%3AImageRegion%20const%26%2C%20mozilla%3A%3Agfx%3A%3ASurfaceFormat%2C%20GraphicsFilter%2C%20unsigned%20int%2C%20double%29 is this as well, but I'd only dare to add it here if someone with knowledge of the code can confirm that.
Crash Signature: , double)] → , double)] [@ gfxSurfaceDrawable::DrawInternal(gfxContext*, gfxRect const&, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&, bool, GraphicsFilter const&, double, gfxMatrix const&)]
Does it make sense to nominate this for tracking?
Flags: needinfo?(kairo)
[Tracking Requested - why for this release]:
(In reply to Benjamin Kerensa [:bkerensa] from comment #3)
> Does it make sense to nominate this for tracking?

Given that it remains at #1 on Nightly and seemingly doesn't get attention, yes.
Flags: needinfo?(kairo)
Assignee: nobody → matt.woodrow
Looks like this happens on windows sometimes, and the old path (FillRect with an empty SurfacePattern) handles it gracefully.
Attachment #8493240 - Flags: review?(bas)
Attachment #8493240 - Flags: review?(bas) → review+
https://hg.mozilla.org/mozilla-central/rev/1f03487d2904
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
I crashed bp-51ad923c-5496-4aac-a6f4-970a72140926 even with this patch, assuming it was in my 2014-09-24 nightly build. 

Install Time	2014-09-24 16:25:39
Product	Firefox
Version	35.0a1
Build ID	20140924030204
Release Channel	nightly
There are no crash reports after build id 20140924030204. Therefore this seems to be fixed.
In any way, something looks wrong, because your crash report (and a lot others too) is of revision 1e2993c99323 which should include the fix. Anyone have an idea what was going on here?
Socorro shows no more crashes over the past 4 weeks, with either of these 3 signatures.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.