toolbar buttons are dim until click in main window

VERIFIED FIXED in mozilla0.9.6

Status

SeaMonkey
Composer
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: sujay, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.6

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
using 10/25 trunk build

1) launch netscape
2) launch composer

toolbar buttons are dimmed out. until you click in the composer
window and start typing...then they appear. 

THIS IS NOT A DUP OF bug 97663

I changed my cache preferences to Once per session and it still does not work.
Kin witnessed
this in my cube also.

Comment 1

17 years ago
Seen on 10/24 also (Kathy and me), but not on 10/23 -- new bug, not a dup of the
older one.  Doesn't seem to matter what the cache pref is.
(Assignee)

Comment 2

17 years ago
Created attachment 55150 [details] [diff] [review]
Fix.
(Assignee)

Comment 3

17 years ago
There is a fundamental change in the "getAttribute()" method: It now returns 
null instead of an empty string when the attribute doesn't exist!
WARNING: This is probably going to cause a lot of bugs!
Status: NEW → ASSIGNED
Keywords: patch, review
Whiteboard: EDITORBASE, FIX IN HAND need r=,sr=
Target Milestone: --- → mozilla0.9.6

Comment 4

17 years ago
Comment on attachment 55150 [details] [diff] [review]
Fix.

sr=kin@netscape.com

Are you going to do a sweep through the editor JS to find
shortcuts like this that assumed a "" string instead of null?
Attachment #55150 - Flags: superreview+
(Assignee)

Comment 5

17 years ago
Yes, other problems because of the new null return are covered by bug 106822.
(Assignee)

Updated

17 years ago
Whiteboard: EDITORBASE, FIX IN HAND need r=,sr= → EDITORBASE, FIX IN HAND need r=

Comment 6

17 years ago
Comment on attachment 55150 [details] [diff] [review]
Fix.

r=hwaara
Attachment #55150 - Flags: review+
(Assignee)

Comment 7

17 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Keywords: patch, review
Resolution: --- → FIXED
Whiteboard: EDITORBASE, FIX IN HAND need r= → EDITORBASE
(Assignee)

Comment 8

17 years ago
*** Bug 106980 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

17 years ago
verified in 10/29 trunk build...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.