If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Weird JavaScript failure when using certain dynamic pages

RESOLVED DUPLICATE of bug 104904

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 104904
16 years ago
16 years ago

People

(Reporter: Jens Fallesen, Assigned: rods (gone))

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Problem found when using the Cisco case open tool with dynamic select boxes.
Demo  copy of page placed on http://www.avic.gg/mozilla/tac.html for testing
purposes.

Go to test page and try to select a technology (upper select box in technology
field). Lower box in same field should then change from "Please select a
technology from above list" to a request for specifying a sub-technology and a
selection of sub-technologies should be available.

This works fine with older versions of Mozilla, eg. 0.9.1, as well as the NS 6.x
derivatives. IE has no problem either. However, newer Mozilla versions (tested
with 0.9.4 and 0.9.5 milestones as well as a few nightly builds, including
20011023).

JavaScript console displays this message:

Error: uncaught exception: [Exception... "Failure"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame :: http://www.avic.gg/mozilla/tac.html
:: getSubTechnologies :: line 266"  data: no]
(Reporter)

Comment 1

16 years ago
I may want to add that the same behaviour is seen under Windows 2000.
jkeiser?  how's this look on your end?  :)

Comment 3

16 years ago
Not JS Engine. Reassigning to HTML Form Controls for further triage - 
Assignee: rogerl → rods
Status: UNCONFIRMED → NEW
Component: Javascript Engine → HTML Form Controls
Ever confirmed: true
QA Contact: pschwartau → madhur

Comment 4

16 years ago
Confirming on Win2k with build 2001102503. I know the restricted area where to
find the original page (CCO required) and it exhibits the same problem.

Comment 5

16 years ago
I don't see this on Linux 2001102406, am I doing something wrong?  When I click
on the link (http://www.avic.gg/mozilla/tac.html) and check the JavaScript
Console, I don't get any errors ...
(Reporter)

Comment 6

16 years ago
jkeiser: Did you try selecting something in the first selection pull-down in the
"Technology" field under "Describe your problem"?

I am currently waiting for my pc to build the latest source I just downloaded
(file dated 27 Oct 16:40 UTC). I expect this build ready when I get up in the
morning, I can then give it another try.

Comment 7

16 years ago
My, my, I seem to have problems reading directions.

I am getting the problem on line 332, but it looks like the same problem. 
Specifically, lines like "form.summary.options[psSelectLength]=null;" are not
working.  This is not happening until the frames have been initialized, though.
 I don't know if this is a dup or not.

Fixed in bug 34297.  Setting dependent.
Depends on: 34297

Comment 8

16 years ago
Fixed with bug 34297 landing.

*** This bug has been marked as a duplicate of 104904 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.