If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Reduced space available in Utility Tray causes several truncations

RESOLVED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: flod, Assigned: albertopq)

Tracking

unspecified
2.1 S5 (26sep)

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.1 verified, b2g-v2.2 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments, 1 obsolete attachment)

With the new design landed in bug 1038723, I keep seeing truncated text in Utility tray notifications because of the bigger font we're using (notification time was fixed in bug 1060928).

Messages that have been perfectly fine from 1.0 to 2.0 are now badly truncated. 
In Italian I'm aware of at least 2 (screenshot notification, downloading updates), but I'm sure there are more.
Component: Gaia::SMS → Gaia::System
Francesco, can you provide us with some example screenshots?
Flags: needinfo?(francesco.lodolo)
Whiteboard: [systemsfe]
Created attachment 8489830 [details]
screenshot.png

These are the two notifications I'm aware of (updated flame on the left, keon right before the update on the right).
Flags: needinfo?(francesco.lodolo)
Note that the "downloading updates" was already truncated in the previous design.
Eric, can you take a look at this? Perhaps we want to decrease the font size further for the notification info in the tray?
Flags: needinfo?(epang)
(In reply to Julien Wajsberg [:julienw] from comment #3)
> Note that the "downloading updates" was already truncated in the previous
> design.

Nope. That's a … part of the string to indicate 'action in progress', not a truncation

http://transvision.mozfr.org/?recherche=download+in+corso%E2%80%A6&repo=gaia&sourcelocale=en-US&locale=it&search_type=strings
Created attachment 8491405 [details]
[Spec] Notifications Sytem Spec.jpg

Hi, I've updated the spec to reduce the size of the font (for the first line).  This should bring things back to the way they used to be.

The font is now 15.333px on HVGA (23px on Flame).  Please let me know if there are any questions, thanks!
Flags: needinfo?(epang)
Alberto, can you help fix this one up?
Flags: needinfo?(apastor)
(Assignee)

Updated

3 years ago
Assignee: nobody → apastor
Flags: needinfo?(apastor)
(Assignee)

Comment 8

3 years ago
Created attachment 8492947 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24270

I'm a little bit confused about the spec, as it doesn't say 15.33px for the first line, but I guess it was a mistake. Eric, could you please review?
Attachment #8492947 - Flags: ui-review?(epang)
Created attachment 8493027 [details]
[Spec] Notifications Sytem Spec

Updated the spec, sorry for the confusion Alberto.  The time stamp should stay as is and the 1st line should only be updated.  My comment now matches the spec :).  Let me know if you have any questions.
Attachment #8491405 - Attachment is obsolete: true
(In reply to Eric Pang [:epang] from comment #9)
> Created attachment 8493027 [details]
> [Spec] Notifications Sytem Spec
> 
> Updated the spec, sorry for the confusion Alberto.  The time stamp should
> stay as is and the 1st line should only be updated.  My comment now matches
> the spec :).  Let me know if you have any questions.

just saw the ui-review flag.  Will take a look when I get a chance! thx
Created attachment 8493048 [details]
2014-09-22-10-43-49.png

Hey Alberto, looks like the 'Update Available' text isn't resized. Can you take a look?  Also, can you check other possibilities to makes sure all notifications are updated?  Thanks!
Flags: needinfo?(apastor)
(Assignee)

Comment 12

3 years ago
Just updated the flag. Will add some tests before r? Thanks!
Flags: needinfo?(apastor)
(Assignee)

Comment 13

3 years ago
^ Last comment wasn't supossed to go here :S
Hi Alberto, the spacing between the 1st and 2nd line is looking tight.  Can you check that it's 1.8rem from baseline to baseline and vertically centered in the space?  Thanks!
Flags: needinfo?(apastor)
(Assignee)

Comment 15

3 years ago
Hey Eric, just updated the patch.

Thanks!
Flags: needinfo?(apastor)
Comment on attachment 8492947 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24270

Looks good now, thanks Alberto!
Attachment #8492947 - Flags: ui-review?(epang) → ui-review+
(Assignee)

Comment 17

3 years ago
Comment on attachment 8492947 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24270

Pinging :gmarty, as he worked on the utility tray :)
Attachment #8492947 - Flags: review?(gmarty)
Comment on attachment 8492947 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24270

Looks good to me. I left a minor comment on Github to avoid conflict with https://bugzilla.mozilla.org/show_bug.cgi?id=1062314 (not sure which one of these two will land first).
Thanks Alberto!
Attachment #8492947 - Flags: review?(gmarty) → review+
(Assignee)

Comment 19

3 years ago
master: https://github.com/mozilla-b2g/gaia/commit/f3aecbdc096ff69446df3dc08060795c2b9bcd59
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 20

3 years ago
[Blocking Requested - why for this release]: Low risk and fixes a UI problem
blocking-b2g: --- → 2.1?
(Assignee)

Comment 21

3 years ago
Comment on attachment 8492947 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24270

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1038723
[User impact] if declined: Truncated notification titles
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): Low risk, css only
[String changes made]: -
Attachment #8492947 - Flags: approval-gaia-v2.1?(fabrice)
Not blocking but lets do the approval process.
blocking-b2g: 2.1? → -
Attachment #8492947 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/b93ee1f62c41c6fb5df739b081b82996d015af90
status-b2g-v2.1: --- → fixed
status-b2g-v2.2: --- → fixed
Target Milestone: --- → 2.1 S5 (26sep)
This issue is verified on Flame 2.1:

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141007000203
Gaia: 7f738edf66b9298bceef8a4981d05d04fd04e540
Gecko: b9d04c58580a
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

The font size is reduced properly on Utility Tray.
========================================================
This issue fails to verify on Flame 2.2. 

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141006040204
Gaia: 470826d13ae130a5c3d572d1029e595105485fb0
Gecko: e0d714f43edc
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

The font size for update-related notifications is bigger than the rest. Filed a new bug 1079394.
QA Whiteboard: [QAnalyst-Triage?][failed-verification]
status-b2g-v2.1: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.