Closed Bug 1067425 Opened 7 years ago Closed 7 years ago

Screen goes black when invoking the share overlay on Android 4.4+

Categories

(Firefox for Android Graveyard :: Overlays, defect, P2)

35 Branch
ARM
Android
defect

Tracking

(fennec+)

RESOLVED WORKSFORME
Tracking Status
fennec + ---

People

(Reporter: aaronmt, Assigned: lucasr)

References

Details

(Keywords: reproducible)

Attachments

(1 file)

Attached video video.mp4
Currently when one uses the share overlay on Android L Preview, the entire screen goes black before the overlay is shown.

See YouTube video: http://youtu.be/nKesevex5t0

This does not happen with other providers such as Google+ seen in the video.
tracking-fennec: --- → ?
Lucas - Can you investigate? You might be our only FE Android L user.
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → 34+
Maybe not entirely restricted to Android L? I noticed today on my Nexus 5 (4.4.4), invoking the share overlay from inside the browser, e.g, on a bookmark, will also black out the screen for a second.
FWIW, I can only reproduce this on L.
If I had to guess, I'd say this is because we specify android:hardwareAccelerated="true" for our application, and that's interacting with the transparent activity.

E.g., 

https://developer.appcelerator.com/question/153905/white-flash-android-when-hardware-accelerated

https://code.google.com/p/android/issues/detail?id=20446
I see this happening on a 4.4.x device too.
Summary: Screen goes black when invoking the share overlay on Android L → Screen goes black when invoking the share overlay on Android 4.4+
tracking-fennec: 34+ → ?
tracking-fennec: ? → +
Priority: -- → P2
I don't even see this at all on the Nexus 9. I blame L Preview.
I don't see this at all on the Nexus 5 with 5.0 (factory image)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.