No way to open MANY links in BACKGROUND tabs ONLY with LEFT click

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: nleo, Unassigned)

Tracking

32 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140830211128

Steps to reproduce:

I google for this

I found that no only I have the problem

http://forums.mozillazine.org/viewtopic.php?f=38&t=2799047
http://stackoverflow.com/questions/2181464/i-need-to-to-open-a-new-window-in-the-background-with-javascript-and-make-sure
http://stackoverflow.com/questions/6213807/open-a-new-tab-with-javascript-but-stay-on-current-tab
http://stackoverflow.com/questions/10812628/open-a-new-tab-in-the-background
http://stackoverflow.com/questions/7522565/how-to-stay-on-current-window-when-the-link-opens-in-new-tab

T try to use browser.tabs.loadDivertedInBackground but it open links in ONE tab always reloading it

I try several JS hack

function openNewBackgroundTab(a){
    var evt = document.createEvent("MouseEvents");
    //the tenth parameter of initMouseEvent sets ctrl key
    evt.initMouseEvent("click", true, true, window, 0, 0, 0, 0, 0,
                                true, false, false, false, 0, null);
    a.dispatchEvent(evt);
  }

  $('a.bgtab').click(function(){
    // openNewBackgroundTab(this);
    open(this.href);
    focus();
  });


Actual results:

I didn't find a solution


Expected results:

There should be a way to open links in background tabs with left click without any modificators

Or maybe just target=blank links
This is known as popunder and we have protections in place to prevent popunders.
Your report is no bug in the product and as an enhancement requests it's a wontfix because i don't know a reason why a normal user would want a feature like this.

In case you need this feature for your own firefox installation you should consider writing an addon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.