Intermittent test_scriptProcessorNodeChannelCount.html | application crashed [@ mozilla::layers::CompositableDataGonkOGL::DeleteTextureIfPresent()]

RESOLVED FIXED in Firefox 34, Firefox OS v2.1

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: RyanVM, Assigned: nical)

Tracking

({crash, intermittent-failure})

Trunk
mozilla35
ARM
Gonk (Firefox OS)
crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox33 unaffected, firefox34 fixed, firefox35 fixed, firefox-esr31 unaffected, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

(Reporter)

Description

4 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=48104519&tree=Mozilla-Aurora

b2g_emulator_vm mozilla-aurora opt test mochitest-3 on 2014-09-15 08:11:51 PDT for push a0808c960664
slave: tst-linux64-spot-656

09:42:01     INFO -  665 INFO TEST-START | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html
09:42:10     INFO -  666 INFO TEST-OK | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | took 9171ms
09:42:21     INFO -  -*- NetworkService: NetworkService shutdown
09:42:21     INFO -  System JS : ERROR resource://gre/modules/BrowserElementParent.jsm:300 - NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIXPCComponents_Utils.isDeadWrapper]
09:42:21     INFO -  System JS : ERROR resource://gre/modules/BrowserElementParent.jsm:300 - NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIXPCComponents_Utils.isDeadWrapper]
09:42:22     INFO -  System JS : ERROR resource://gre/modules/IndexedDBHelper.jsm:121 - UnknownError: The operation failed for reasons unrelated to the database itself and not covered by any other error code.
09:42:22     INFO -  System JS : ERROR jar:file:///system/b2g/omni.ja!/components/B2GAppMigrator.js:88 - NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]
09:42:29     INFO -  mozcrash Downloading symbols from: http://pvtbuilds.pvt.build.mozilla.org/pub/mozilla.org/b2g/tinderbox-builds/mozilla-aurora-emulator/20140915064010/b2g-34.0a2.en-US.android-arm.crashreporter-symbols.zip
09:42:51  WARNING -  PROCESS-CRASH | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | application crashed [@ mozilla::layers::CompositableDataGonkOGL::DeleteTextureIfPresent()]
09:42:51     INFO -  Crash dump filename: /tmp/tmpY_5urB/4680c0e5-a0e0-fb59-59eed489-5cb611d7.dmp
09:42:51     INFO -  Operating system: Android
09:42:51     INFO -                    0.0.0 Linux 2.6.29-g41a03df #22 Thu Jun 26 10:59:09 CST 2014 armv7l Android/full/generic:4.0.4.0.4.0.4/OPENMASTER/eng.cltbld.20140915.095624:eng/test-keys
09:42:51     INFO -  CPU: arm
09:42:51     INFO -       0 CPUs
09:42:51     INFO -  Crash reason:  SIGSEGV
09:42:51     INFO -  Crash address: 0x240
09:42:51     INFO -  Thread 21 (crashed)
09:42:51     INFO -   0  libxul.so!mozilla::layers::CompositableDataGonkOGL::DeleteTextureIfPresent() [GLContext.h : 2692 + 0x0]
09:42:51     INFO -       r4 = 0x464b2700    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
09:42:51     INFO -       r8 = 0x00000004    r9 = 0x45beef88   r10 = 0x00000000    fp = 0x4573fd88
09:42:51     INFO -       sp = 0x4573fc50    lr = 0x40e8b5f7    pc = 0x40e8b5c6
09:42:51     INFO -      Found by: given as instruction pointer in context
09:42:51     INFO -   1  libxul.so!mozilla::layers::CompositableDataGonkOGL::ClearData() [TextureHostOGL.cpp:a0808c960664 : 134 + 0x3]
09:42:51     INFO -       r4 = 0x474c3000    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
09:42:51     INFO -       r8 = 0x00000004    r9 = 0x45beef88   r10 = 0x00000000    fp = 0x4573fd88
09:42:51     INFO -       sp = 0x4573fc58    pc = 0x40e8b5f7
09:42:51     INFO -      Found by: call frame info
09:42:51     INFO -   2  libxul.so!mozilla::layers::CompositableHost::Detach(mozilla::layers::Layer*, unsigned int) [CompositableHost.h:a0808c960664 : 239 + 0x5]
09:42:51     INFO -       r4 = 0x474c3000    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
09:42:51     INFO -       r8 = 0x00000004    r9 = 0x45beef88   r10 = 0x00000000    fp = 0x4573fd88
09:42:51     INFO -       sp = 0x4573fc60    pc = 0x40e6d9c1
09:42:51     INFO -      Found by: call frame info
09:42:51     INFO -   3  libxul.so!mozilla::layers::ThebesLayerComposite::CleanupResources() [ThebesLayerComposite.cpp:a0808c960664 : 163 + 0x9]
09:42:51     INFO -       r4 = 0x474c3000    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
09:42:51     INFO -       r8 = 0x00000004    r9 = 0x45beef88   r10 = 0x00000000    fp = 0x4573fd88
09:42:51     INFO -       sp = 0x4573fc68    pc = 0x40e7779d
09:42:51     INFO -      Found by: call frame info
09:42:51     INFO -   4  libxul.so!mozilla::layers::ThebesLayerComposite::Destroy() [ThebesLayerComposite.cpp:a0808c960664 : 77 + 0x5]
09:42:51     INFO -       r4 = 0x474c3000    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
09:42:51     INFO -       r8 = 0x00000004    r9 = 0x45beef88   r10 = 0x00000000    fp = 0x4573fd88
09:42:51     INFO -       sp = 0x4573fc70    pc = 0x40e776c9
09:42:51     INFO -      Found by: call frame info
09:42:51     INFO -   5  libxul.so!mozilla::ipc::PBackgroundChild::OnEnteredCxxStack() [PBackgroundChild.cpp : 376 + 0x3]
09:42:51     INFO -       r4 = 0x471c0a40    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
09:42:51     INFO -       r8 = 0x00000004    r9 = 0x45beef88   r10 = 0x00000000    fp = 0x4573fd88
09:42:51     INFO -       sp = 0x4573fc78    pc = 0x40c1b895
09:42:51     INFO -      Found by: call frame info
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1071761
(Assignee)

Comment 7

4 years ago
Looks like either
1) CompositableDataGonkOGL::DeleteTextureIfPresent() should check that mCompositor != nullptr (in which case gl() will return nullptr
2) or we make sure to destroy mTexture before changing the compositor (probably makes more sense)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 15

4 years ago
Fixed as part of Bug 1072491, no crash in inbound/central since it landed and the fix should get uplifted soon.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
Assignee: nobody → nical.bugzilla
status-b2g-v2.1: --- → fixed
status-b2g-v2.2: --- → fixed
status-firefox33: --- → unaffected
status-firefox34: --- → fixed
status-firefox35: --- → fixed
Depends on: 1072491
Target Milestone: --- → mozilla35
(Reporter)

Updated

4 years ago
status-firefox-esr31: --- → unaffected
You need to log in before you can comment on or make changes to this bug.