HTML5 offline webpage doesn't load after firefox update

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: lists, Unassigned)

Tracking

37 Branch
x86
Windows
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140831201958

Steps to reproduce:

1) Have a html5  offline web application loaded with <html manifest="/mf.appcache">
2) Sucessfully run web app in offline mode all the time.  Page loads correctly with or without network connectivity based on the contents of the manifest.
3) Upgrade Firefox from 30 to 31 or 31 to 32



Actual results:

Firefox presents a "Problem loading page" Firefox is currently in offline mode and can't browse the Web.  Since this is an offline accessible web page, firefox should never display this error, if the offline cache is up-to-date, which it was prior to the update. 

This error happens even when the network is available and the webserver and the online source of the page is available.    This problem first happened when upgradeing from Firefox 30 to 31, and is still present when upgrading to Firefox 32. (ie. 31 ->32).  

All non-html5 pages that are only "online" continue work without issue.  


Expected results:

Page should have been displayed as normal. 

To repeat, the webserver in question is up and running and accessbile from Chrome and other browsers.  Affects Linux (Fedora 20 official package) and Windows, direct install from Mozilla.   Are you tagging the offline webcache with the FF version?  

The only work around is to clear history with a timeframe of "Everything" and ensure that the "Offline Website Data" is checked.    Once that is done, the page will then correctly load with or without the network being online. This only happens after a firefox update, until the offline website data is cleared.  

This never happened with any version of Firefox prior to 31.  This page has been active for more than a year, and no previous updates ever did this. 100+ users affected.

Comment 1

5 years ago
(In reply to lists from comment #0)
> User Agent: Mozilla/5.0 (X11; Linux i686; rv:32.0) Gecko/20100101
> Firefox/32.0
> Build ID: 20140831201958
> 
> Steps to reproduce:
> 
> 1) Have a html5  offline web application loaded with <html
> manifest="/mf.appcache">

Could you attach or provide a minimal selfcontained testcase showing the issue, please. It would help to test an debug.
Flags: needinfo?(lists)
(Reporter)

Comment 2

5 years ago
Posted file Test Case - html
File 1 of 4
Flags: needinfo?(lists)
(Reporter)

Comment 3

5 years ago
(Reporter)

Updated

5 years ago
Attachment #8490193 - Attachment description: mz.html → Test Case - html
(Reporter)

Updated

5 years ago
Attachment #8490194 - Attachment description: test - appcache file → Test Case - appcache
(Reporter)

Comment 4

5 years ago
Posted file Test Case - css
(Reporter)

Comment 5

5 years ago

Comment 6

5 years ago
For testing your testcase, what are the STR? Just checking "Work offline" in the File option? Do I need to clear the cache before testing?
(Reporter)

Comment 7

5 years ago
Hi,

No, you don't need to clear the cache first.  Just load the page, check to make sure that the window.applicationCache.status is 2.  

Sorry to be dumb, but I don't understand STR?  

I've only tested this with https, since that's our use case. 

Site normally runs on iis (6 and 7). 

Then close the page.  Let firefox upgrade then try to access the page after the upgrade.

Comment 8

5 years ago
STR= Steps To Reproduce ;)
(Reporter)

Comment 9

5 years ago
Hi OK - thanks.

Using Firefox 31 and https

1) Launch Firefox 31.
2) Access the site via https://server/mz.html - page loads from server - stores cache according to manifest.
3) Close the page or tab.
4) Verify offline access 
4-a) Unplug, turn-off, or disable all network interfaces
4-b) Visit the same url - page loads from offline website data cache correctly.
4-c) Re-enable, turn-on or plug-in all network interfaces disabled in 4-a)
4-d) Ensure normal network access from Firefox
5) Upgrade to Firefox 32
6) Visit the same url - Firefox produces the "Firefox is currently in offline mode and can't browse the Web."
7) Clear recent history - Timeframe = Everything, options, Cache,Active Logons, Offline Website Data
6) Visit the same url - loads from the server.
(Reporter)

Comment 10

5 years ago
Still broken in FF 34
Version: 32 Branch → 34 Branch

Updated

4 years ago
Component: General → Networking
(Reporter)

Comment 11

4 years ago
Still broken for https (Secure) offline web apps in 37.x non-secure http://  works fine. What security are you checking for if it is https:// that gets dropped in a firefox Version update?  This is a very serious bug and should be addressed. You should not block access to appcache resources originally loaded via https:  on firefox version upgrades.
(Reporter)

Updated

4 years ago
OS: Linux → All
(Reporter)

Updated

4 years ago
OS: All → Windows
(Reporter)

Updated

4 years ago
Version: 34 Branch → 37 Branch
appcache being retired for sw
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.