If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add support for NTSLink to auto config

RESOLVED DUPLICATE of bug 1185366

Status

Webtools
ISPDB Database Entries
RESOLVED DUPLICATE of bug 1185366
3 years ago
2 years ago

People

(Reporter: Ryan Cain, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8489647 [details]
ntslink.xml

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20140716183446

Comment 1

2 years ago
ntslink.net

      Configuration found in Mozilla ISP Database


IMAP: imap-mail.outlook.com, 993, SSL,      password-cleartext 
POP3: pop-mail.outlook.com,  995, SSL,      password-cleartext
SMTP: smtp-mail.outlook.com, 587, STARTTLS, password-cleartext
 Username: %EMAILADDRESS%
Unfortunately this is another instance of MX overlap between the outlook.com consumer service and the office365 business service covered by bug 1185366.  The MX lookup is coming to the wrong conclusion of using imap-mail.outlook.com.  We can see that from running "dig -t mx ntslink.net" and that we get "ntslink-net.mail.protection.outlook.com." back.

I'm going to dupe this to bug 1185366 since with that fix MX lookup could eliminate the need for many, many entries in the ISPDB.  In the meantime, ntslink can/should self-host as described at https://developer.mozilla.org/en-US/docs/Mozilla/Thunderbird/Autoconfiguration#Configuration_server_at_ISP
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1185366
You need to log in before you can comment on or make changes to this bug.