Sync (29.0+) fails when profiles.ini has IsRelative=0

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
23 days ago

People

(Reporter: firefox, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140911151253

Steps to reproduce:

On Windows 7 x64 running Firefox 31.0.1, in the profiles.ini, I have "IsRelative=0" and "Path=d:\\dev\\caches\\firefox.vanilla". [I swap channels and OS's a few times a day some days]

[As a caveat, I do use NTFS Directory Junctions/Links to make sure my system drive is trashable with a minute's notice, so the following CMD commands are run when my Windows User Profile is created: 
mklink /d %userprofile%\AppData\Roaming\mozilla d:\dev\caches\prf_mozilla
mklink /d %userprofile%\AppData\Roaming\thunderbird d:\dev\caches\prf_thunderbird
This is, however, unrelated as far as I can tell.)]




Actual results:

When trying to sync, "Sync Error: An unknown error occurred." appears where the add-on bar is/was and the sync will not sync add-ons. Bookmarks, however, do synchronise without issue.

On a completely blank User Profile, sync works fine, since the profile directory is randomly generated and IsRelative=1 in the profiles.ini. This has been confirmed by removing the folders mentioned in reproduction and syncing from scratch.


Expected results:

Add-ons (and possibly other settings) should have synchronised as easily as bookmarks do.
(Reporter)

Updated

4 years ago
OS: All → Windows 7
Hardware: All → x86_64
(Reporter)

Comment 1

4 years ago
Created attachment 8489661 [details]
IsRelative=0, custom profile path (not syncing addons)

Firefox 32.0.1 on Windows 7 x64
(Reporter)

Comment 2

4 years ago
Created attachment 8489663 [details]
IsRelative=1, autogenerated profile path (addons sync perfectly)

Firefox 32.0.1 on Windows 7 x64
(Reporter)

Comment 3

4 years ago
Version is 32.0.1 (not 31.0.1 as mentioned in original). The installed add-on in first attachment was manually installed before sync process (a home-grown extension). The issue appears regardles of its installation status.
Flags: needinfo?(markh)
I can't reproduce this, so I expect the addon manager code has changed over the last 3 years to better support this. If you are still having trouble, feel free to reopen this bug, bug please also see https://wiki.mozilla.org/CloudServices/Sync/File_a_desktop_bug for how to find logs which should include information about the underlying issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(markh)
Resolution: --- → WORKSFORME
(Assignee)

Updated

23 days ago
Component: Firefox Sync: Cross-client → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.