[Ringtones][OTA] The sound of customed ringtone & alert will disappear after upgrading from 2.0 to 2.1

RESOLVED INVALID

Status

Firefox OS
Gaia::Ringtones
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: gchang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
### Steps:
1. Flash device to 2.0
   Gaia      7edd3b0b9f65c3dde235c732d270e43e055a1254
   Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f2a6fb59a7f5
   BuildID   20140914160201
   Version   32.0
2. adb push 2 mp3 files to sd card
3. create a customed ringtone and a alert and set them as default ringtone & alert using these 2 mp3
4. Power off device
5. Remove sd card
6. Power on device
7. Use another device to make a phone call and generate a screen shot to make sure the sound of ringtone & alert are set
8. upgrade to 2.1 via OTA
9. Use another device to make a phone call to this device and generate a screen shot again

### Expected:
The sound of the ringtone and alert should be expected as we set in 2.0

### Actual:
We can hear the sound of ringtone and alert at the first 1~2 seconds, then, the sound disappears and the device only vibrates.

### Reproduce rate
always

### Version:
Device    flame
Gaia      e731a63484c532168f4de6dc1eeb4c6612ad73a9
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/868cc9e5e32a
BuildID   20140915160206
Version   34.0a2
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
(Reporter)

Comment 2

4 years ago
This is not a bug. The device is muted. That's why the sound disappeared.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID

Updated

4 years ago
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.