[Bluetooth][PTS][Bluedroid][2.1][KitKat] AVRCP - TC_TG_PTT_BV_01_I Inconclusive

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: echang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [POVB])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8489801 [details]
TC_TG_PTT_BV_01_I.zip

### STR
Test case : TC_TG_PTT_BV_01_I started
	- MTC: SDP Service record was successfully registered.
	- A2DP SNK SDP Service record successfully registered
	- A2DP SNKsuccessfully registered
	- MTC: IUT successfully responded to AVDTP CONNECT.
	- MTC: IUT successfully accepted AVCTP channel connection.
	- MTC INCONC: User indicated the IUT did not accept the PLAY command.
	- MTC INCONC: User indicated the IUT did not accept the STOP command.
	- MTC INCONC: User indicated the IUT did not accept the PLAY command.
	- MTC INCONC: User indicated the IUT did not accept the PAUSE command.
	- AVDTP: Exiting AVDTP1 PTC
	- AVCTP: Exiting AVCTP1 PTC
	- CM_PTC_EXIT
	- MTC: Test case ended
Final Verdict : Inconclusive

### Version
1. flash v166
https://mozilla.app.box.com/files/0/f/2230155871
2. flash gecko, gaia from tinderbox
https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/mozilla-aurora-flame-kk-eng/20140909171114/
(Reporter)

Comment 1

4 years ago
DUT doesn't response to any of the commands sent from PTS in this case.
QA Whiteboard: [COM=Bluetooth]
(In reply to Eric Chang [:ericcc] [:echang] from comment #0)
> Created attachment 8489801 [details]
> TC_TG_PTT_BV_01_I.zip
> 	- MTC INCONC: User indicated the IUT did not accept the PLAY command.
> 	- MTC INCONC: User indicated the IUT did not accept the STOP command.
> 	- MTC INCONC: User indicated the IUT did not accept the PLAY command.
> 	- MTC INCONC: User indicated the IUT did not accept the PAUSE command.

This looks strange for me. PLAY/STOP command is not involved in Gecko bluetooth, but bluedroid stack related.
Assignee: nobody → shuang
I tested Nexus 5 with branch v2.1, this test case can pass. I wonder this is something related to CAF bluedroid. I will take a deep look on flame-kk.
I actually suspect this is something related to missing implementation of CAF bluedroid added callback (connection_priority_callback). When I tested with Nexus5, a2dp connection established. But on flame-kk, we did not see incoming a2dp connection.
I think this problem caused by bug 1003591. CAF bluedroid introduced priority connection.
To prove this is relate to CAF change, you can patch workaround i attached.
Created attachment 8490777 [details] [diff] [review]
bug1067747 workaround to impelment CAF connection_priority (v2.1)
This is just an experiment patch to prove this is something to do with CAF changes.
Please note, due to we cannot introduce CAF build flag in gecko, so we cannot check-in my patch in bug 1067747 anyway. This still need to wait for CAF to resolve!
Attachment #8490777 - Attachment description: bug1067747 workaround to impelment CAF connection_priority → bug1067747 workaround to impelment CAF connection_priority (v2.1)

Updated

4 years ago
QA Whiteboard: [COM=Bluetooth] → [COM=Bluetooth PTS]
Assignee: shuang → nobody
Whiteboard: [POVB]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 10

4 years ago
Verified on
Gaia-Rev        778ebac47554e1c4b7e9a952d73e850f58123914
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/aa98eb8873a2
Build-ID        20141005160206
Version         34.0a2
Status: RESOLVED → VERIFIED

Comment 11

4 years ago
Could not pass this case after retest multiple times. Reopen this bug.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
After Bug1079087 landed, I can pass this test case using today's PVT aurora build[1].
[1] https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-aurora-flame-kk-eng/2014/10/2014-10-07-17-01-48/
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

4 years ago
Verified okay
Gaia-Rev        e9b9ee15eded2671656efbc40f8437ae8a61d55c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/49bd5bad84d2
Build-ID        20141007170148
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141007.202947
FW-Date         Tue Oct  7 20:29:58 EDT 2014
Bootloader      L1TC00011840
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.