Closed Bug 1067850 Opened 6 years ago Closed 6 years ago

Assertion failure: !IsUninitializedLexical((activation.regs()).sp[-1]), at vm/Interpreter.cpp

Categories

(Core :: JavaScript Engine, defect)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1067805

People

(Reporter: gkw, Unassigned)

Details

(Keywords: assertion, regression, testcase)

Attachments

(1 file)

(function() {
    let x = let({} = 7) x
})()

asserts js debug shell on m-c changeset 3b7921328fc1 with --no-threads at Assertion failure: !IsUninitializedLexical((activation.regs()).sp[-1]), at vm/Interpreter.cpp.

Debug configure flags:

CC="clang -Qunused-arguments" CXX="clang++ -Qunused-arguments" AR=ar sh /Users/skywalker/trees/mozilla-central/js/src/configure --target=x86_64-apple-darwin12.5.0 --enable-debug --enable-optimize --enable-nspr-build --enable-more-deterministic --with-ccache --enable-gczeal --enable-debug-symbols --disable-tests

autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   https://hg.mozilla.org/mozilla-central/rev/7027efe7fae3
user:        Shu-yu Guo
date:        Mon Sep 15 16:30:45 2014 -0700
summary:     Bug 1001090 - Part 1: Implement let temporal dead zone in the frontend and interpreter. (r=Waldo)

Shu-yu, is bug 1001090 a possible regressor?
Flags: needinfo?(shu)
This is a dup of bug 1067805. I messed up and pushed the wrong version of a patch.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(shu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1067805
You need to log in before you can comment on or make changes to this bug.