Closed Bug 10681 Opened 21 years ago Closed 20 years ago

[DOGFOOD] Cannot set selection between consecutive <BR> tags

Categories

(Core :: DOM: Editor, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: buster, Assigned: mjudge)

References

()

Details

(Whiteboard: [PDT+])

in the editor, you cannot get a caret between two blocks.  Users find this
disconcerting.
*** Bug 5640 has been marked as a duplicate of this bug. ***
Assignee: sfraser → jfrancis
I think joe's gonna have to attack this one.
Assignee: jfrancis → buster
joe is confused.  so confused that he is talking about himself in the third
person.

i need a more specific bug.  i don't have much of anything to do with the caret,
or with selection's response to user clicks or arrow keys.  if you mean that the
selection is not ending up properly beween blocks after some edit operation, then
pass on the details, por favor.

assigning back to buster for further details/dispensation.
I understood this to mean that you can't put the caret in the dead area between
two <P>s.
Target Milestone: M10
Summary: [DOGFOOD] Cannot set selection between blocks → [DOGFOOD] Cannot set selection between consecutive <BR> tags
changed the summary.  Let's focus on this test case:

<HTML><BODY>
a<BR><BR>b
</BODY></HTML>

So visually we have:
-----------------------------
a

b
-----------------------------
The expected selection/navigation behaviors are:
1. clicking in the white space between 'a' and 'b' gives you a caret on the
blank line, and typing at this point inserts text between the <BR>s.
2. clicking after 'a' on the same line as 'a' gives you a caret on that first
line.  a single right-arrow key should give you a selection between the two
lines, and a second right-arrow key should give you a selection just in front of
'b'.
Assignee: buster → mjudge
mike, this is in your court now, correct?
*** Bug 10923 has been marked as a duplicate of this bug. ***
adding myself to cc: list.
Blocks: 12658
*** Bug 8481 has been marked as a duplicate of this bug. ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
fixed test simon's test case if you DARE!! ;)
Status: RESOLVED → VERIFIED
verified in 9/22 build.
Whiteboard: [PDT+]
Putting on [PDT]+ radar.
You need to log in before you can comment on or make changes to this bug.