Trying to open the task switcher while already inside the task switcher will make the tasks overlap

RESOLVED FIXED in 2.1 S5 (26sep)

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: robertbindar, Assigned: sfoster)

Tracking

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Steps:
- Open 2, 3 apps
- Open the task switcher
- while still inside the task switcher, hold the home button and try to open the task switcher again
- move between tasks, you'll see them overlapped.
(Assignee)

Comment 1

4 years ago
Grrr, thanks for spotting this Robert. We lost our guards against showing while showing somewhere along the way.
Assignee: nobody → sfoster
Target Milestone: --- → 2.1 S5 (26sep)
(Assignee)

Comment 2

4 years ago
Created attachment 8490319 [details] [review]
Put back show while showing guards + unit tests.
Attachment #8490319 - Flags: review?(alive)
(Assignee)

Updated

4 years ago
Blocks: 1061324
Whiteboard: [systemsfe]
Comment on attachment 8490319 [details] [review]
Put back show while showing guards + unit tests.

Makes sense, r=me
Attachment #8490319 - Flags: review?(alive) → review+
(Assignee)

Comment 4

4 years ago
Merged to master: https://github.com/mozilla-b2g/gaia/commit/b7d63d77dba5a886e728c7634fc4343ef068b016
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

4 years ago
Note this is blocking bug 1061324, if that uplifts we should take this too.
Duplicate of this bug: 1068333
Duplicate of this bug: 1068833
You need to log in before you can comment on or make changes to this bug.